marsik_11
@marsik_11
I'm from Uzbekistan. 27 y.o. Full Stack Developer

Не устанавливаеться Yii2 расширения через Composer. Как исправить?

У меня такой проблема. Я питаюсь установит Yii2 расширения. Но Composer меня дает вот такуя ошибку. Что мне делать?
composer require 2amigos/yii2-selectize-widget:~1.0
The "yiisoft/yii2-composer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
./composer.json has been updated
The "yiisoft/yii2-composer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Running composer update 2amigos/yii2-selectize-widget
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - yiisoft/yii2-composer 2.0.5 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.
    - yiisoft/yii2 2.0.11 requires yiisoft/yii2-composer ~2.0.4 -> satisfiable by yiisoft/yii2-composer[2.0.5].
    - yiisoft/yii2 is locked to version 2.0.11 and an update of this package was not requested.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.
  • Вопрос задан
  • 34 просмотра
Решения вопроса 1
@tukreb
Читать ошибку кто будет?
You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.

Ставьте себе комзер 1 версии.
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
kawabanga
@kawabanga
Бью себя по рукам за каждый ответ на глупый вопрос
yiisoft/yii2 is locked to version 2.0.11
- выставьте последний актуальный yii2.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы