@Sazoks

Как установить старую версию Flask?

Доброго времени суток всем!
Такая проблема: пишу семестровый проект на первом курсе. Пишу его на Flask'e.
Для работы с базой данных я решил использовать SQLAlchemy, а именно ORM в нем.

Суть проблемы в том, что во всех примерах и книжках, что я нашел, используется следующая запись для импорта:
from flask.ext.sqlalchemy import SQLAlchemy
Но в моей версии Flask's просто нет ext.
Окей, подумал я. Скачал отдельно модуль flask_sqlalchemy.
Заработал. Создал модели, создал таблицы в БД. Ура!

Но на этом проблемы не закончились. Во все примерах для работы с БД используются сессии и такая вот запись:
db.session.add(model_obj)
Model.query.all()

Это я привел для примера. Так вот ни то, ни другое у меня не работает.
Тогда я понял, что, видимо, у меня просто самая новая версия Flask'a и модуля SQLAlchemy.
В связи с этим прошу ткнуть носом, как установить нужную версию Flask'a, чтобы все работало. Либо, хоть это не тема вопроса, подскажите где найти актуальную информацию для последней версии. Офф. доки очень недружелюбные, как по-мне.

Спасибо!
  • Вопрос задан
  • 23 просмотра
Пригласить эксперта
Ответы на вопрос 1
Вы должны использовать флаг --force-reinstall. Чтобы обновить или понизить пакет до определенной версии, вы должны использовать флаг --force-reinstall. Приведенная ниже команда должна работать.

pip install --force-reinstall flask==1.0.2

Источник: https://coderoad.ru/50571372/%D0%9A%D0%B0%D0%BA-%D...
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы