Терминал zsh при вызове приложения обращается к старой версии программы, как исправить?

Установил через homebrew midnight-commander версия 4.26, но по команде mc возникает ошибка, которая ссылается на отсутствие файла версии 4.20:
zsh: no such file or directory: /usr/local/Cellar/midnight-commander/4.8.20/libexec/mc/mc-wrapper.sh


Как направить команду вызова на правильную версию?
  • Вопрос задан
  • 92 просмотра
Решения вопроса 1
Andrew_Pinkerton
@Andrew_Pinkerton
Не так страшны первые 99%, как оставшиеся 99%
В файле ~/.bash_profile (в вашем случае ~/.zshrc) найдите строчку alias mc= отредактируйте (укажите путь к актуальной версии mc-wrapper) и сохраните изменения
После этого выполните:
source ~/.zshrc
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы