@Stas506

Почему не работает сеть в Vlan в виртулку CentOS на Hyper-V?

Есть сетка для телефонов 192.168.100.0, она в vlan 5 (если не ошибаюсь) и отдельный коммутатор для них. Этот коммутатор так же подключен к общей сети фирмы 10.24.2.0.
Есть старая АТС (FreePBX на железке) одной сеть (eth0) в 10.24.2.0 и другой (eth2.5) в 192.168.100.0. На ней так же развернут DHCP.
Я поднял Windows Server 2019 Core и на нём поднял Hyper-V. Одну сетевуху я воткнул в коммутатор для телефонов и настроил виртуальный коммутатор (LanATS.jpeg 60407fbadad97957118134.jpeg )
На Hyper-V создал виртуалку и развернут на неё FreePBX. Дал её 2 сетевые карты - одна смотрит в 10.24.2.0 а другая в 192.168.100.0 (Lan vos.jpeg 604081c96a735432799064.jpeg ).
На новой АТС я прописал IP из разных сетей (я не перепутал сетевухи) и у меня не пингуются телефоны. (Ifconfig_ping.jpeg 60408a7a9d768679912550.jpeg
Вот вывод route:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default gateway 0.0.0.0 UG 0 0 0 eth0
10.24.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
link-local 0.0.0.0 255.255.0.0 U 1002 0 0 eth0
link-local 0.0.0.0 255.255.0.0 U 1003 0 0 eth1
192.168.100.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1

В чём может быть проблема?
  • Вопрос задан
  • 58 просмотров
Пригласить эксперта
Ответы на вопрос 1
vesper-bot
@vesper-bot
Любитель файрволлов
Проверьте порт свитча, в который воткнут адаптер #3 сервера Hyper-V. Ваша конфигурация сети показывает, что все пакеты, отправляемые в адаптер, идут с tagged vlan 5, порт должен принимать на своей стороне tagged vlan 5, чтобы пакеты попали в пятый влан. Скорее всего, порт на свитче стоит в режиме access vlan 5, в этом случае со стороны сервера VLAN tag указывать не нужно (указать vlan id 0). Иначе конфигурировать порт в trunk и разрешать принимать на нем tagged vlan 5.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы