@MihailAlex

Ошибка при установке YII2 advanced через composer на Ubuntu 18.04. В чем проблема?

Устанавливаю новый проект на yii2 advanced При запуске composer update получаю следующую ошибку:
mihailkri@mihailkri:/var/www/veloguru/advanced$ composer update
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- codeception/verify 1.1.0 requires phpunit/phpunit > 6.0 -> satisfiable by phpunit/phpunit[6.0.1, ..., 6.5.14, 7.0.0, ..., 7.5.20, 8.0.0, ..., 8.5.13, 9.0.0, ..., 9.5.0].
- codeception/verify 0.5.0 requires php 5.6.* -> your php version (7.2.24) does not satisfy that requirement.
- phpunit/phpunit[6.0.1, ..., 6.5.14, 7.0.0, ..., 7.5.20, 8.0.0, ..., 8.5.13] require ext-dom * -> it is missing from your system. Install or enable PHP's dom extension.
- phpunit/phpunit[9.0.0, ..., 9.2.6] require php ^7.3 -> your php version (7.2.24) does not satisfy that requirement.
- phpunit/phpunit[9.3.0, ..., 9.3.8] require php ^7.3 || ^8.0 -> your php version (7.2.24) does not satisfy that requirement.
- phpunit/phpunit[9.3.9, ..., 9.5.0] require php >=7.3 -> your php version (7.2.24) does not satisfy that requirement.
- Root composer.json requires codeception/verify ~0.5.0 || ~1.1.0 -> satisfiable by codeception/verify[0.5.0, 1.1.0].

To enable extensions, verify that they are enabled in your .ini files:
- /etc/php/7.2/cli/php.ini
- /etc/php/7.2/cli/conf.d/10-mysqlnd.ini
- /etc/php/7.2/cli/conf.d/10-opcache.ini
- /etc/php/7.2/cli/conf.d/10-pdo.ini
- /etc/php/7.2/cli/conf.d/20-calendar.ini
- /etc/php/7.2/cli/conf.d/20-ctype.ini
- /etc/php/7.2/cli/conf.d/20-curl.ini
- /etc/php/7.2/cli/conf.d/20-exif.ini
- /etc/php/7.2/cli/conf.d/20-fileinfo.ini
- /etc/php/7.2/cli/conf.d/20-ftp.ini
- /etc/php/7.2/cli/conf.d/20-gd.ini
- /etc/php/7.2/cli/conf.d/20-gettext.ini
- /etc/php/7.2/cli/conf.d/20-iconv.ini
- /etc/php/7.2/cli/conf.d/20-json.ini
- /etc/php/7.2/cli/conf.d/20-mbstring.ini
- /etc/php/7.2/cli/conf.d/20-mysqli.ini
- /etc/php/7.2/cli/conf.d/20-pdo_mysql.ini
- /etc/php/7.2/cli/conf.d/20-phar.ini
- /etc/php/7.2/cli/conf.d/20-posix.ini
- /etc/php/7.2/cli/conf.d/20-readline.ini
- /etc/php/7.2/cli/conf.d/20-shmop.ini
- /etc/php/7.2/cli/conf.d/20-sockets.ini
- /etc/php/7.2/cli/conf.d/20-sysvmsg.ini
- /etc/php/7.2/cli/conf.d/20-sysvsem.ini
- /etc/php/7.2/cli/conf.d/20-sysvshm.ini
- /etc/php/7.2/cli/conf.d/20-tokenizer.ini
You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

Понимаю, что что то в конфигурации пыхи надо подправить, но не знаю что именно. Подскажите плиз.
  • Вопрос задан
  • 49 просмотров
Решения вопроса 1
alexey-m-ukolov
@alexey-m-ukolov Куратор тега PHP
ext-dom * -> it is missing from your system. Install or enable PHP's dom extension.

P.S. Новый проект стоит начинать на актуальной версии языка — 7.4 или 8.0.
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@eandr_67
web-программист (*AMP, Go, JavaScript, вёрстка).
Установлен PHP версии 7.2, а компоненты Yii2 требуют версию PHP не ниже 7.3.
Тут не php.ini надо править, а устанавливать из репозитория PHP версии 7.3 (или 7.4, или 8.0).
И настраивать конфигурацию Nginx / Apache на эту версию PHP.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы