Как решить проблему с установлением npm пакета?

Делаю проект на Next.js - фрейворке над React.js. Для работы с индикатором загрузки устанавливаю npm пакет nextjs-progressbar. В терминале выводиться ошибка, что она может означать и как решить эту проблему?

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: next-course@0.1.0
npm ERR! Found: react@17.0.1
npm ERR! node_modules/react
npm ERR!   react@"17.0.1" from the root project
npm ERR!   peer react@"^16.6.0 || ^17" from next@10.0.4
npm ERR!   node_modules/next
npm ERR!     next@"10.0.4" from the root project
npm ERR!     peer next@"^6.0.0 || ^7.0.0 || ^8.0.0 || ^9.0.0 || ^10.0.0" from nextjs-progressbar@0.0.7
npm ERR!     node_modules/nextjs-progressbar
npm ERR!       nextjs-progressbar@"*" from the root project
npm ERR!   1 more (react-dom)
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer react@"^16.0.0" from nextjs-progressbar@0.0.7
npm ERR! node_modules/nextjs-progressbar
npm ERR!   nextjs-progressbar@"*" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! 
npm ERR! See /home/andrew/.npm/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/andrew/.npm/_logs/2020-12-30T07_49_58_318Z-debug.log
  • Вопрос задан
  • 91 просмотр
Решения вопроса 1
poly-titova
@poly-titova Автор вопроса
Так как проблема была с зависимостями, значит надо было поменять пару версий. В данном случае так:
"dependencies": {
    "next": "9.4.4",
    "react": "16.13.1",
    "react-dom": "16.13.1"
  }
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы