@Fanzoo

Почему не могу правильно подключить плагин copy webpack?

После подключения плагина copy-webpack-plugin, не могу его нормально импортировать.
5f99385bf0099787195021.png
Что приводит к ошибкам при сборке проекта :
spoiler

[webpack-cli] ValidationError: Invalid options object. Copy Plugin has been initialized using an options object that does not match the API schema.
 - options[0] misses the property 'patterns'. Should be:
   [non-empty string | object { from, to?, context?, globOptions?, filter?, toType?, force?, flatten?, transform?, cacheTransform?, transformPath?, noErrorOnMissing? }, ...] (should not have fewer than 1 item)
    at validate (/home/an/WebstormProjects/Excel-course/node_modules/schema-utils/dist/validate.js:104:11)
    at new CopyPlugin (/home/an/WebstormProjects/Excel-course/node_modules/copy-webpack-plugin/dist/index.js:54:31)
    at Object.<anonymous> (/home/an/WebstormProjects/Excel-course/webpack.config.js:19:5)
    at Module._compile (/home/an/WebstormProjects/Excel-course/node_modules/v8-compile-cache/v8-compile-cache.js:194:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1157:10)
    at Module.load (internal/modules/cjs/loader.js:985:32)
    at Function.Module._load (internal/modules/cjs/loader.js:878:14)
    at Module.require (internal/modules/cjs/loader.js:1025:19)
    at require (/home/an/WebstormProjects/Excel-course/node_modules/v8-compile-cache/v8-compile-cache.js:161:20)
    at requireConfig (/home/an/WebstormProjects/Excel-course/node_modules/webpack-cli/lib/groups/ConfigGroup.js:73:18) {
  errors: [
    {
      keyword: 'required',
      dataPath: '[0]',
      schemaPath: '#/required',
      params: [Object],
      message: "should have required property 'patterns'",
      schema: [Object],
      parentSchema: [Object],
      data: [Object],
      children: [Array]
    }
  ],
  schema: {
    definitions: { ObjectPattern: [Object], StringPattern: [Object] },
    type: 'object',
    additionalProperties: false,
    properties: { patterns: [Object], options: [Object] },
    required: [ 'patterns' ]
  },
  headerName: 'Copy Plugin',
  baseDataPath: 'options',
  postFormatter: null
}



В официальной документации что то не нашлось решений.
Может кто сталкивался с такой проблемой? Прошу помочь.
  • Вопрос задан
  • 43 просмотра
Решения вопроса 1
delphinpro
@delphinpro
frontend developer
Как это в официальной документации не нашлось решений?
Вы внимательнее посмотрите — https://webpack.js.org/plugins/copy-webpack-plugin/

да и в ошибке ясно написано: message: "should have required property 'patterns'",
schema: {
definitions: { ObjectPattern: [Object], StringPattern: [Object] },
type: 'object',
additionalProperties: false,
properties: { patterns: [Object], options: [Object] },
required: [ 'patterns' ]
},
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы