@d99999

Ошибка при работе с Docker, как исправить?

configure: error: Package requirements (libzip >= 0.11 libzip != 1.3.1 libzip != 1.7.0) were not met:

Package 'libzip', required by 'virtual:world', not found
Package 'libzip', required by 'virtual:world', not found
Package 'libzip', required by 'virtual:world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBZIP_CFLAGS
and LIBZIP_LIBS to avoid the need to call pkg-config.


FROM php:7.4-fpm-alpine

ARG ENVIRONMENT="production"
ENV DEPENDENSIES="git libzip mysql-client curl libmcrypt libmcrypt-dev openssh-client icu-dev libxml2-dev libxslt-dev espeak "
ENV BUILD_DEPENDENSIES="g++ make autoconf"
ENV EXTENSIONS="pdo pdo_mysql mysqli soap intl zip xsl bcmath xml sockets"
ENV COMPOSER_VERSION="1.8.0"

#RUN docker-php-ext-enable mcrypt

#RUN docker-php-ext-install mcrypt
#RUN docker-php-ext-configure mcrypt

RUN apk update && apk upgrade \
    && apk add --no-cache --virtual .build-deps ${PHPIZE_DEPS} ${BUILD_DEPENDENSIES} \
    && apk add --no-cache ${DEPENDENSIES} \
    && docker-php-ext-install ${EXTENSIONS} \
    && pecl install redis \
    && docker-php-ext-enable redis \
    && apk del .build-deps \
    && rm -rf /tmp/* \
    && rm -rf /var/cache/apk/*

# INSTALL composer
RUN mkdir /etc/composer \
    && wget https://getcomposer.org/installer -P /etc/composer \
    && cd /etc/composer && php ./installer  --filename=composer --verion=${COMPOSER_VERSION} --install-dir=/bin \
    && rm /etc/composer/installer \
    && chmod a+x /bin/composer

COPY init-php.sh /init.sh

ENTRYPOINT ["/init.sh"]
  • Вопрос задан
  • 63 просмотра
Пригласить эксперта
Ответы на вопрос 1
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы