ettaluni
@ettaluni
ERROR MEME

Как настроить eclipse для разработки под Qt?

Нужно разработать приложение под Linux, так как я из веба думал использовать Node + Electron. Но Node оказалось таким днищем, неуправляемый грузовиком со своей асинхронностью и скриптовостью(что собственно логично).

Позже покопался решил идти в С\С++, фрэеймворк выбрал Qt, но так и не смог его настроить под eclipse. Ни одного примера нет, все устаревшее 2009 года, под новый eclipse не ставиться. Кто пишет на Qt под Linux-Desktop, просьба помочь короткой инструкцией как начать разработку под Qt в eclipse CDT 2020-06\2020-10, ОС Debian.

Eclipse выбрал потому, что позже придется и под Java код править, если есть другая IDE с таким-же широким охватом языков, буду рад рассмотреть.

Также eclipse бесплатна, ни я сам ни предприятие не смогут позволить полноценное платное IDE.

С qtcreator не справился не предлагайте
  • Вопрос задан
  • 47 просмотров
Пригласить эксперта
Ответы на вопрос 1
Adamos
@Adamos
QtCreator.
Если вам одновременно нужны C++ и Java - возможно, стоит посмотреть на Android Studio.
Eclipse после знакомства с ними вызывает только одно желание - закопать.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы