@Mamol27

Как поставить webkit с qt4 на Ubuntu 18?

Здравствуйте.
Есть легаси проект. Переехал на удаленку. Все поставил, а qt4.8.7 не подтягивает webkit. Не пойму что делать.
Список установленных библиотек:
spoiler

libqt4-dbus/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-declarative/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-declarative-gestures/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-declarative-particles/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-designer/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-dev/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен]
libqt4-dev-bin/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-help/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен]
libqt4-network/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен]
libqt4-opengl/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-opengl-dev/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-qt3support/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-script/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-scripttools/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-sql/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-sql-mysql/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-sql-psql/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен]
libqt4-sql-sqlite/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-svg/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-test/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-xml/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
libqt4-xmlpatterns/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
python-qt4/bionic,now 4.12.1+dfsg-2 amd64 [установлен, автоматически]
python-qt4-dbus/bionic,now 4.12.1+dfsg-2 amd64 [установлен, автоматически]
qt4-default/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен]
qt4-demos/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен]
qt4-designer/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
qt4-dev-tools/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
qt4-doc/bionic,bionic,now 4:4.8.7+dfsg-7ubuntu1 all [установлен, автоматически]
qt4-doc-html/bionic,bionic,now 4:4.8.7+dfsg-7ubuntu1 all [установлен]
qt4-linguist-tools/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен, автоматически]
qt4-qmake/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен]
qt4-qmlviewer/bionic,now 4:4.8.7+dfsg-7ubuntu1 amd64 [установлен]

gir1.2-javascriptcoregtk-4.0/bionic-updates,bionic-security,now 2.28.0-0ubuntu0.18.04.3 amd64 [установлен, автоматически]
gir1.2-webkit2-4.0/bionic-updates,bionic-security,now 2.28.0-0ubuntu0.18.04.3 amd64 [установлен, автоматически]
libglib-object-introspection-perl/bionic,now 0.044-2 amd64 [установлен, автоматически]
libjavascriptcoregtk-1.0-0/bionic,now 2.4.11-3ubuntu3 amd64 [установлен, автоматически]
libjavascriptcoregtk-1.0-dev/bionic,now 2.4.11-3ubuntu3 amd64 [установлен, автоматически]
libjavascriptcoregtk-4.0-18/bionic-updates,bionic-security,now 2.28.0-0ubuntu0.18.04.3 amd64 [установлен, автоматически]
libqt5webchannel5/bionic,now 5.9.5-0ubuntu1 amd64 [установлен, автоматически]
libqt5webkit5/bionic,now 5.212.0~alpha2-7ubuntu1 amd64 [установлен, автоматически]
libqtwebkit4/bionic,now 2.3.2-0ubuntu13 amd64 [установлен]
libqtwebkit4-dbg/bionic,now 2.3.2-0ubuntu13 amd64 [установлен]
libwebkit2gtk-4.0-37/bionic-updates,bionic-security,now 2.28.0-0ubuntu0.18.04.3 amd64 [установлен, автоматически]
libwebkitgtk-1.0-0/bionic,now 2.4.11-3ubuntu3 amd64 [установлен, автоматически]
libwebkitgtk-dev/bionic,now 2.4.11-3ubuntu3 amd64 [установлен]

  • Вопрос задан
  • 100 просмотров
Пригласить эксперта
Ответы на вопрос 1
vt4a2h
@vt4a2h
Senior software engineer (C++/Qt/boost)
Ну что-то вроде:
sudo apt-get install -y libqt4-webkit
Или libqtwebkit4

Я просто даже не знаю, как там на Убунте пакеты называются. У меня другая операционная система и вот так пакет называется: libQtWebKit4.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы