@furcifer

Почему не запускается openServer на php-7.4?

Здравствуйте. Подскажите, как быть.
Добавляю php-7.4 на openServer. Следую инструкции, которую нашел на форуме https://ospanel.io/:
.................................
Как и любую другую версию PHP, чтобы прикрутить PHP 7.4, проделайте следующее:
1. Скачайте дистрибутив: https://windows.php.net/downloads/qa/ph ... 16-x86.zip
2. Создайте новый каталог PHP-7.4 в подкаталоге с модулями PHP: .\modules\php
3. Распакуйте содержимое скачанного дистрибутива в созданный каталог
4. Скопируйте файлы cacert.pem, composer.bat и composer.phar, а также весь каталог PEAR из подкаталога .\modules\php\PHP-7.3 в подкаталог ./modules/php/PHP-7.4
5. Создайте копию файла .\userdata\config\PHP-7.3_php.ini и переименуйте копию в .\userdata\config\PHP-7.4_php.ini
6. Откройте в блокноте файл .\userdata\config\PHP-7.4_php.ini и отключите/закомментируйте расширения, которые отсутствуют в версии 7.4.
7. В окно настроек OSPanel, на закладке Модули, выберите PHP-7.4.
8. Сохраните настройки и запустите сервер.
9. Проверьте версию PHP, пройдя по ссылке: 127.0.0.1/openserver/phpinfo.php
......................................

Сервер не запускается
Подскажите в чем может быть проблема, и как можно добиться желаемого?
Заранее большое спасибо

Логи и настройки:
5e7495a93ec8a153508231.png
  • Вопрос задан
  • 323 просмотра
Пригласить эксперта
Ответы на вопрос 1
@pavelpol
Попробуй использовать Nginx вместо Apache. Для apache нужны какие-то дополнительные танцы с бубном, о чем говорит то, что в openserver отдельные версии apache для разных версий php.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы