Почему не устанавливается пакет?

Кто-нибудь сталкивался с таким? У меня команда npm view @babel/traverse показывает версию 7,6,3 , а текущая версия 7,7,0.
Из-за этого не ставится пакет @babel/core , т.к. у него в зависимости указана версия 7,7,0 а у меня не видит ее.

npm cache verify делал
package-lock.json удалил.

Вот текущий package.json
{
  "name": "start-template",
  "version": "1.0.0",
  "description": "My start Template",
  "main": "index.js",
  "author": "Salamatin Anatoliy",
  "license": "MIT",
  "devDependencies": {
    "@babel/core": "^7.7.0",
    "@babel/preset-env": "^7.6.3",
    "browser-sync": "^2.26.7",
    "del": "^5.1.0",
    "gulp": "4.0",
    "gulp-autoprefixer": "^7.0.1",
    "gulp-babel": "^8.0.0",
    "gulp-cache": "^1.1.3",
    "gulp-cached": "^1.1.1",
    "gulp-cheerio": "^0.6.3",
    "gulp-concat": "^2.6.1",
    "gulp-csscomb": "^3.0.8",
    "gulp-csso": "^3.0.1",
    "gulp-imagemin": "^6.1.1",
    "gulp-plumber": "^1.2.1",
    "gulp-pug": "^4.0.1",
    "gulp-rename": "1.4.0",
    "gulp-replace": "1.0.0",
    "gulp-sass": "^4.0.2",
    "gulp-sourcemaps": "^2.6.5",
    "gulp-svg-sprite": "^1.5.0",
    "gulp-svgmin": "^2.2.0",
    "gulp-uglify": "^3.0.2",
    "imagemin-jpeg-recompress": "^6.0.0"
  },
  "dependencies": {
    "normalize.css": "^8.0.1",
    "svg4everybody": "^2.1.9"
  }
}
  • Вопрос задан
  • 146 просмотров
Решения вопроса 1
@farcer Автор вопроса
Решилось прописанием npm set registry
Ответ написан
Комментировать
Пригласить эксперта
Ответы на вопрос 2
IceRD
@IceRD
Если нужна конкретная версия, попробуйте принудительно указать ее
npm i -D @babel/traverse@7.7.0
Ответ написан
Комментировать
@flatronus
инженер-строитель
npm install '@babel/core' пропиши кавычки
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы