vera_ira
@vera_ira
Делаю приложение по изучению Иврит (Python Kotlin)

Почему при деплое heroku не видит библиотеку pywin32?

В проекте на python использую библиотек pywin32.
Но при деплое на heroku выдает такую ошибку. Подскажите, может версия нужна другая (уже пробовала 220-224) или heroku не работает с этой библиотекой? Как решить?

Python app detected
-----> Installing requirements with pip
       Collecting pywin32==221 (from -r /tmp/build_cfd4b292c180af4ad511e0d7f5a41816/requirements.txt (line 19))
         Could not find a version that satisfies the requirement pywin32==224 (from -r /tmp/build_cfd4b292c180af4ad511e0d7f5a41816/requirements.txt (line 19)) (from versions: )
       No matching distribution found for pywin32==224 (from -r /tmp/build_cfd4b292c180af4ad511e0d7f5a41816/requirements.txt (line 19))
 !     Push rejected, failed to compile Python app.
 !     Push failed
  • Вопрос задан
  • 334 просмотра
Решения вопроса 2
@AWEme
Retard Soft Inc.
Есть подозрение, что библиотеки для Windows не очень любят работать из под линукса...
Ответ написан
Комментировать
alfss
@alfss
https://career.habr.com/alfss
Это расширение только для win32, а там nix* система
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы