Возможно ли адвертайзить IPV6 префикс на Mikrotik?

От провайдера получили следующие настройки:
NET: 2a03:ffff:ffff:100::/64
GW: 2a03:ffff:ffff:100::1/64

По данным настройкам пробую конфигурировать Микротик для раздачи данного адресного пространства в локалке. Ниже привожу настройки, после которых сам Микротик успешно выходит в интернет. ether11_wan - WAN-интерфейс
Настройки ipv6 вар.1
/ipv6 export verbose     
# oct/24/2018 19:48:16 by RouterOS 6.43.2
# software id = R233-59RQ
#
# model = RouterBOARD 1100x4
# serial number = 793107A16F12
/ipv6 pool
add name=ipv6_pool prefix=2a03:ffff:ffff:100::/64 prefix-length=66
/ipv6 address
add address=::/64 advertise=yes disabled=no eui-64=no from-pool=ipv6_pool interface=IPV6 no-dad=no
add address=2a03:ffff:ffff:100::2/64 advertise=no disabled=no eui-64=no from-pool="" interface=ether11_wan no-dad=no
/ipv6 nd
set [ find default=yes ] advertise-dns=no advertise-mac-address=no disabled=no hop-limit=unspecified interface=all managed-address-configuration=no mtu=unspecified other-configuration=no ra-delay=3s ra-interval=3m20s-10m ra-lifetime=30m \
    reachable-time=unspecified retransmit-interval=unspecified
/ipv6 nd prefix default
set autonomous=yes preferred-lifetime=1w valid-lifetime=4w2d
/ipv6 route
add !bgp-as-path !bgp-atomic-aggregate !bgp-communities !bgp-local-pref !bgp-med !bgp-origin !bgp-prepend !check-gateway disabled=no distance=1 dst-address=::/0 gateway=2a03:ffff:ffff:100::1 !route-tag scope=30 target-scope=10
/ipv6 settings
set accept-redirects=yes-if-forwarding-disabled accept-router-advertisements=yes-if-forwarding-disabled forward=yes max-neighbor-entries=8192


Роуты
0 A S  dst-address=::/0 gateway=2a03:ffff:ffff:100::1 gateway-status=2a03:ffff:ffff:100::1 reachable via  ether11_wan distance=1 scope=30 target-scope=10 
1 ADC  dst-address=2a03:ffff:ffff:100::/64 gateway=ether11_wan gateway-status=ether11_wan reachable distance=0 scope=10



Далее следует сам вопрос - а как мне это префикс /64 раздать в локалку, ведь если я попробую это сделать, то микрот закономерно считает что GW - он сам? IPV6 - локальный бридж.
Настройки ipv6 вар.2
/ipv6 export verbose 
# oct/24/2018 19:33:31 by RouterOS 6.43.2
# software id = R233-59RQ
#
# model = RouterBOARD 1100x4
# serial number = 793107A16F12
/ipv6 pool
add name=ipv6_pool prefix=2a03:ffff:ffff:100::/64 prefix-length=66
/ipv6 address
add address=2a03:ffff:ffff:100::2/64 advertise=no disabled=no eui-64=no \
    from-pool="" interface=ether11_wan no-dad=no
/ipv6 nd
set [ find default=yes ] advertise-dns=no advertise-mac-address=no disabled=no \
    hop-limit=unspecified interface=all managed-address-configuration=no mtu=\
    unspecified other-configuration=no ra-delay=3s ra-interval=3m20s-10m \
    ra-lifetime=30m reachable-time=unspecified retransmit-interval=unspecified
/ipv6 nd prefix default
set autonomous=yes preferred-lifetime=1w valid-lifetime=4w2d
/ipv6 route
add !bgp-as-path !bgp-atomic-aggregate !bgp-communities !bgp-local-pref \
    !bgp-med !bgp-origin !bgp-prepend !check-gateway disabled=no distance=1 \
    dst-address=::/0 gateway=2a03:ffff:ffff:100::1 !route-tag scope=30 \
    target-scope=10
/ipv6 settings
set accept-redirects=yes-if-forwarding-disabled accept-router-advertisements=\
    yes-if-forwarding-disabled forward=yes max-neighbor-entries=8192


Роуты
0 A S  dst-address=::/0 gateway=2a03:ffff:ffff:100::1 gateway-status=2a03:ffff:ffff:100::1 reachable via  IPV6 distance=1 scope=30 target-scope=10 
1 ADC  dst-address=2a03:ffff:ffff:100::/64 gateway=ether11_wan,IPV6 gateway-status=ether11_wan reachable,IPV6 reachable distance=0 scope=10



Что я делаю не так? Есть конечно еще мнение, что пров некорректно сконфигурировад свою сторону и должен был либо смаршрутизировать префикс через link-local адрес, либо выделить отдельный префикс под маршрутизацию.
  • Вопрос задан
  • 998 просмотров
Решения вопроса 2
@Wexter
Что-то у вас в конфиге такая каша что аж страшно становится.
А вообще вот неплохой мануал https://www.medo64.com/2018/03/setting-ipv6-on-mik...
Если у вас префикс не по dhcp выдаётся то создайте пул с вашим префиксом вручную, либо добавьте адрес без пула
Ну и для примера мой конфиг (sit1 - 6to4 туннель Hurricane Electric, вместо него ваш интерфейс к провайдеру)
# oct/24/2018 20:26:47 by RouterOS 6.43.2
# software id = 1LD8-H6Z7
#
# model = RouterBOARD 750G r3
# serial number = 6F38065E7063
/ipv6 pool
add name=pool_lan prefix=2001:470:xxxx:xxxx::/64 prefix-length=64
/ipv6 address
add address=::1 from-pool=pool_lan interface=bridge_lan
add address=2001:470:xxxx:xxxx::2 advertise=no interface=sit1
/ipv6 nd
add advertise-dns=yes hop-limit=64 interface=bridge_lan managed-address-configuration=yes other-configuration=yes ra-interval=5m-10m
/ipv6 route
add distance=1 dst-address=2000::/3 gateway=2001:470:xxxx:xxxx::1
Ответ написан
Zarom
@Zarom Автор вопроса
Связались с тех-отделом провайдера. По факту была выявлена ошибка в предосталвенной информации. Данный префикс /64 должен был быть выделен для маршрутизации между нашим роутером и провайдерским. Для анонсирования в нашей ЛВС был предоставлен дополнительно префикс /48.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы