Adorne
@Adorne
Социопат, социофоб, мезантрап.

Почему до D-Link DGS-3420-28TC не доходят OSPF Hello?

Есть три роутера, все в одном широковещательном домене:
  1. D-Link DGS-3420-28TC
  2. виртуализированный OPNsense
  3. виртуализированный BSD Router Project


Конфиги OSPF:
D-Link DGS-3420-28TC

config route preference ospfIntra 80
config route preference ospfInter 90
config route preference ospfExt1 110
config route preference ospfExt2 115
enable ecmp ospf
create ospf area 0.0.0.1 type normal
config ospf ipif adm_net area 0.0.0.1 priority 1 hello_interval 10 dead_interval 40
config ospf ipif adm_net authentication none metric 1 state disable passive disable
config ospf ipif adm_net distribute_list_in none
config ospf ipif srv_mgmt area 0.0.0.1 priority 1 hello_interval 10 dead_interval 40
config ospf ipif srv_mgmt authentication none metric 1 state enable passive disable
config ospf ipif srv_mgmt distribute_list_in none
config ospf ipif sw_mgmt area 0.0.0.1 priority 1 hello_interval 10 dead_interval 40
config ospf ipif sw_mgmt authentication none metric 1 state enable passive disable
config ospf ipif sw_mgmt distribute_list_in none
config ospf ipif voip_test area 0.0.0.1 priority 1 hello_interval 10 dead_interval 40
config ospf ipif voip_test authentication none metric 1 state disable passive disable
config ospf ipif voip_test distribute_list_in none
config ospf ipif virt area 0.0.0.1 priority 1 hello_interval 10 dead_interval 40
config ospf ipif virt authentication none metric 1 state enable passive disable
config ospf ipif virt distribute_list_in none
config ospf ipif System area 0.0.0.1 priority 1 hello_interval 10 dead_interval 40
config ospf ipif System authentication none metric 1 state enable passive disable
config ospf ipif System area 0.0.0.1
config ospf ipif System priority 1
config ospf ipif System hello_interval 10
config ospf ipif System dead_interval 40
config ospf ipif System metric 1
config ospf ipif System state enable
config ospf ipif System passive disable
config ospf ipif System distribute_list_in none
config ospf router_id 10.10.5.254
enable ospf
disable ospfv3
OPNsense

Current configuration:
!
log file /var/log/quagga.log
!
interface enc0
!
interface lo0
!
interface pflog0
!
interface pfsync0
!
interface vtnet0
!
interface vtnet1
!
router ospf
ospf router-id 10.10.5.1
redistribute connected
passive-interface vtnet0
network 10.10.5.1/24 area 0.0.0.1
default-information originate
!
ip forwarding
ipv6 forwarding
!
line vty
!
end
BSDRP

!
! Zebra configuration saved from vty
! 2017/11/30 08:42:43
!
frr version 2.0
frr defaults traditional
!
!
!
!
!
interface enc0
!
interface lo0
!
interface vtnet0
!
interface vtnet1
!
router ospf
ospf router-id 10.10.5.4
redistribute connected
network 10.10.5.0/24 area 0.0.0.1
network 172.16.0.0/24 area 0.0.0.1
!
line vty
!


Конфиги интерфейсов:
D-Link

config out_band_ipif ipaddress 192.168.0.1/24
config out_band_ipif state enable
config out_band_ipif gateway 0.0.0.0
config ipif_mac_mapping ipif System mac_offset 0
config ipif System ipaddress 192.168.2.254/24
config ipif System vlan default
config ipif_mac_mapping ipif virt mac_offset 1
create ipif virt 10.10.200.254/24 virt state enable
config ipif virt proxy_arp disable local disable
config ipif_mac_mapping ipif adm_net mac_offset 5
create ipif adm_net 10.0.144.30/27 adm state enable
config ipif adm_net proxy_arp disable local disable
config ipif_mac_mapping ipif sw_mgmt mac_offset 2
create ipif sw_mgmt 10.10.10.254/24 sw state enable
config ipif sw_mgmt proxy_arp disable local disable
config ipif_mac_mapping ipif srv_mgmt mac_offset 4
create ipif srv_mgmt 10.10.5.254/24 srv state enable
config ipif srv_mgmt proxy_arp disable local disable
config ipif_mac_mapping ipif voip_test mac_offset 3
create ipif voip_test 10.10.111.254/24 voip_test state enable
config ipif voip_test proxy_arp disable local disable
config ipif virt ip_mtu 1500
config ipif System ip_mtu 1500
config ipif adm_net ip_mtu 1500
config ipif sw_mgmt ip_mtu 1500
config ipif srv_mgmt ip_mtu 1500
config ipif voip_test ip_mtu 1500
OPNsense

vtnet0: flags=8843 metric 0 mtu 1500
options=6c00b8
ether aa:a0:f1:1a:1a:b2
inet netmask 0xffffff00 broadcast
inet6 fe80::a8a0:f1ff:fe1a:1ab2%vtnet0 prefixlen 64 scopeid 0x1
nd6 options=21
media: Ethernet 10Gbase-T
status: active
vtnet1: flags=8843 metric 0 mtu 1500
options=6c00b8
ether 56:65:cf:cc:60:ab
inet 10.10.5.1 netmask 0xffffff00 broadcast 10.10.5.255
inet6 fe80::5465:cfff:fecc:60ab%vtnet1 prefixlen 64 scopeid 0x2
nd6 options=21
media: Ethernet 10Gbase-T
status: active
BSDRP

vtnet0: flags=8843 metric 0 mtu 1500
options=6800bb
ether 56:8a:54:6f:4d:94
hwaddr 56:8a:54:6f:4d:94
inet6 fe80::548a:54ff:fe6f:4d94%vtnet0 prefixlen 64 scopeid 0x1
inet 10.10.5.4 netmask 0xffffff00 broadcast 10.10.5.255
nd6 options=21
media: Ethernet 10Gbase-T
status: active
vtnet1: flags=8843 metric 0 mtu 1500
options=6800bb
ether 92:6c:e8:c8:51:84
hwaddr 92:6c:e8:c8:51:84
inet6 fe80::906c:e8ff:fec8:5184%vtnet1 prefixlen 64 scopeid 0x2
inet 172.16.0.1 netmask 0xffffff00 broadcast 172.16.0.255
nd6 options=21
media: Ethernet 10Gbase-T
status: active


OPNsense использует, очевидно, Quagga, а BSDRP - FRR. OSPF настраиваю первый раз.
Проблема: соседские отношения установлены в Full все, кроме D-Link <-> OPNsense. OPNsense добавил его в соседи со статусом пока Init, а вот D-Link видит 0 пакетов OSPF от OPNsense. Вот такие пакеты ловятся на OPNsense:
spoiler

14:27:01.309552 IP (tos 0xc0, ttl 1, id 3474, offset 0, flags [none], proto OSPF (89), length 68)
10.10.5.254 > 224.0.0.5: OSPFv2, Hello, length 48
Router-ID 10.10.5.254, Area 0.0.0.1, Authentication Type: none (0)
Options [External]
Hello Timer 10s, Dead Timer 40s, Mask 255.255.255.0, Priority 1
Designated Router 10.10.5.4, Backup Designated Router 10.10.5.254
Neighbor List:
10.10.5.4

14:27:08.726681 IP (tos 0xc0, ttl 1, id 33320, offset 0, flags [none], proto OSPF (89), length 72)
10.10.5.4 > 224.0.0.5: OSPFv2, Hello, length 52
Router-ID 10.10.5.4, Area 0.0.0.1, Authentication Type: none (0)
Options [External]
Hello Timer 10s, Dead Timer 40s, Mask 255.255.255.0, Priority 1
Designated Router 10.10.5.4, Backup Designated Router 10.10.5.254
Neighbor List:
10.10.5.1
10.10.5.254

14:27:10.112393 IP (tos 0xc0, ttl 1, id 47171, offset 0, flags [none], proto OSPF (89), length 72)
10.10.5.1 > 224.0.0.5: OSPFv2, Hello, length 52
Router-ID 10.10.5.1, Area 0.0.0.1, Authentication Type: none (0)
Options [External]
Hello Timer 10s, Dead Timer 40s, Mask 255.255.255.0, Priority 1
Designated Router 10.10.5.4, Backup Designated Router 10.10.5.1
Neighbor List:
10.10.5.4
10.10.5.254


Уже полдня пытаюсь понять, что не так.
Помогите подружить D-Link и OPNsense, плиз.
  • Вопрос задан
  • 456 просмотров
Решения вопроса 1
Adorne
@Adorne Автор вопроса
Социопат, социофоб, мезантрап.
Пока проблема не решилась, буду переносить маршрутизацию на BSDRP. Большое спасибо Mystray за помощь в диагностике.
P. S. В конце концов отказался от дистрибутивов *sense (там ещё и IPsec оказался глючным до жути), сработал D-Link и BSDRP, пока всё отлично.
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы