Casper-SC
@Casper-SC
.NET программист

Приложение построенное под .NET 4.5, но имеющее библиотеки, построенные до .NET 3.5 должно ли работать на .NET 4.5?

То есть если в проекте есть библиотеки от 2.0, 3.5, 4.5, то все эти версии дотнета нужно ставить?

Сразу скажу, что сейчас нет времени проверять всё это. Если кто-то знает, то прошу поделиться информацией.
  • Вопрос задан
  • 349 просмотров
Решения вопроса 1
@John_Nash
coder
2.0-3.5
4.0-4.6
это 2 различные ветки. Так что придется ставить
Ответ написан
Пригласить эксперта
Ответы на вопрос 2
yarosroman
@yarosroman Куратор тега C#
C# the best
Да все. мажорные версии не взаимозаменяемы, минорные да. 4.7 заменяет и 4.6 и 4.5 и 4.0, 4.x не заменяет 3.5 и 2.0, 3.5 не заменяет 2.0.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
от 3 500 до 4 000 $
Itiviti Санкт-Петербург
До 230 000 ₽
WB—Tech Москва
от 140 000 до 160 000 ₽