@beegrowth

Bootstrap 4, стоит ли?

Добрый день! Нужен совет ...
Должен сделать тестовое задание, сверстать psd с использованием бутстрап.
Задумался можно ли уже брать 4 версию для такого задания, кто использовал? Вижу она не везде поддерживается. Или лучше 3 заюзать?!
Короче, вопрос... что лучше использовать, чтобы произвести хорошее впечатление?
  • Вопрос задан
  • 7423 просмотра
Решения вопроса 2
webinar
@webinar
Учим yii: https://youtu.be/-WRMlGHLgRg
Использование решений в альфа версии - идиотизм. Есть некоторые люди, которые со мной не согласятся, им Вы понравитесь. Но те же люди не осудят Вас за использование последнее стабильной версии.
Ответ написан
webirus
@webirus
Тыжверстальщик! Наверстай мне упущенное...
Мне лично не внушает доверия контора, которая просит сделать тестовое на бутстрапе.
Представляю, какие там сайты...

Что касается вопроса, делайте на 3-м. 4-й пока сыроват, чтобы использовать на продакшне.
Если бы делали для себя сайт, я бы сказал "Попробуйте", потому как свой сайт всегда можно модернизировать.
А тестовое или сайт для клиентов "Нет, не надо на 4-м".

Чтобы произвести впечатление, сделайте свою сетку :)
И сверстайте так, чтобы работало даже в IE6, а фреймворк, 3 или 4, тут вообще не играет роли.
Ответ написан
Пригласить эксперта
Ответы на вопрос 5
Krasnodar_etc
@Krasnodar_etc
little front
Для тестового задания смело берите 4. Тут отпадает надобность в старых недобраузерах, зато флексбоксы - одно удовольствие.
Кроме того, альфа 4 бутстрама весьма стабильна. У меня пока что проблем не было

Вообще, здесь можно развести холивар на тему, нужно ли подстраиваться под старые браузеры, но мне сегодня лень)

P.S. - забыл. Вам весь бутстрап или только сетка? Сетку лучше бы отдельно вставить и не грузить огромный бутстрап
Ответ написан
webrevenue
@webrevenue
Веб-дизайнер и SEO оптимизатор
Все зависит от конторы. Скорее всего в вашем случае нужно делать на 3м, а так по идее 4й более гибкий и там flexbox, но нет поддержки ие 8-10)
Ответ написан
arsenty
@arsenty
Full Stack Designer
Если в задании явно указана необходимость использования бутстрапа, то следует спросить, обязательно ли использовать текущую стабильную версию или можно воспользоваться четвёртой, в качестве эксперимента. Вопрос в первую очередь к автором тестового задания, не к сообществу тостера.
Ответ написан
Wolfnsex
@Wolfnsex Куратор тега CSS
Если не хочешь быть первым - не вставай в очередь!
Bootstrap 4, стоит ли?
Стоит, сразу как выйдет в релиз. Пока её чёт жутко колбасит с этими альфами... Она даже не бета. Если релиз Вашего проекта намечается к моменту выхода стабильной версии BS-4 (как например, один из наших проектов), то я думаю стоит однозначно. В ином случае, попробуйте как-нибудь в качестве основной ОС и рабочих программ поустанавливать альфа-релизы, желательно всего, что сможете найти, после нескольких секунд/минут/дней работы в таком окружении - многие вопросы на тему "стоит ли использовать альфа-версии софта" отпадут сами собой :)
Ответ написан
alexfilus
@alexfilus
Fullstack разработчик
Задача именно так сформулирована? Именно бутстрап нужен?
Просто если это не принципиально, а нужно именно использовать сетку и фреймворк, то я бы взял Foundation. Он вполне стабилен и там давно уже на flex сетка. Если использовать бутстрап принципиально, то лучше пользоваться стабильной версией.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы