@e-hot

Как разобраться с ошибкой в php-amqplib в Symfony2?

Приветствую всех.
Нужна помощь, кто сталкивался с похожей ситуацией:
1. Есть проект на локальной машине Ubuntu 14.04+nginx+mariadb+php5-fpm+rabbitmq.
2. Проект на Symfony2. Для работы с rabbitmq в SF2 установлен php-amqplib - все работает отлично, никаких нареканий и ошибок.
3. Точно такая же ( 1в1 ) конфигурация рабочего сервера на VPS и все точно так же с Symfony2 с php-amqplib - вплоть до версий php, SF2 библиотек, прав и владельцев на папки и файлы и т.д., но выдается ошибка:
2016/12/21 09:35:34 [error] 893#0: *292 FastCGI sent in stderr: "PHP message: PHP Fatal error: Class 'PhpAmqpLib\Connection\AMQPConnection' not found in
4. Поискал по инету по этой теме - основная ссылка на отсутствие в php.ini упоминания extension=amqp.so, но у меня изначально на локальной версии проекта все работает и без extension=amqp.so. Кто в курсе, разъясните, пожалуйста - в чем проблема на самом деле. С RabbitMQ сталкиваюсь на практике первый раз, до понимания каких-то нюансов еще не дорос.
Заранее спасибо.
  • Вопрос задан
  • 520 просмотров
Пригласить эксперта
Ответы на вопрос 1
prototype_denis
@prototype_denis
Symfony
В php.ini подключите либу. Возможно вы смотрите php.ini для "fpm", но есть ещё и "cli" PHP_SAPI
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы