Новый продукт начинать на PHP 5.3 или PHP 5.4?

Интересует вопрос о распространённости PHP 5.4. Стоит ли начинать делать новый коробочный продукт на нём? Или всё же придётся на PHP 5.3?
  • Вопрос задан
  • 5082 просмотра
Решения вопроса 1
charliez
@charliez
Please note that the PHP 5.3 series will enter an end of life cycle and receive only critical fixes as of March 2013. All users of PHP are encouraged to upgrade to PHP 5.4. © php.net
Ответ написан
Пригласить эксперта
Ответы на вопрос 3
nazarpc
@nazarpc
Open Source enthusiast
5.4 более перспективно, да и писать удобнее. Поддержка будет появляться по мере спроса. А так, как у вас в 2013 всё ещё возникают вопросы — вот и хостеры не спешат. Вот если от них начнут уходить, тогда и задумаются.

Если продукт новый — однозначно 5.4!
Ответ написан
TrueDrago
@TrueDrago
Как-то так дела обстоят:

Version 5.2 — 49.6%
Version 5.3 — 44.9%
Version 5.1 — 3.2%
Version 5.4 — 2.2%
Version 5.0 — 0.1%
Version 5.5 — less than 0.1%

http://w3techs.com/technologies/details/pl-php/5/all
Ответ написан
Fesor
@Fesor
Full-stack developer (Symfony, Angular)
Можно сделать на PHP 5,3 с опциональной возможностью использования плюшек 5,4. Так сделано к примеру в Silex.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы