@VanKrock

Как в npm установить все зависимости?

Как при установке модуля установить все требуемые зависимости?

npm i angular2 --save

выдает:
+-- angular2@2.0.0-beta.7
+-- UNMET PEER DEPENDENCY es6-promise@^3.0.2
+-- UNMET PEER DEPENDENCY es6-shim@^0.33.3
+-- UNMET PEER DEPENDENCY reflect-metadata@0.1.2
+-- UNMET PEER DEPENDENCY rxjs@5.0.0-beta.2
`-- UNMET PEER DEPENDENCY zone.js@0.5.15

npm WARN angular2@2.0.0-beta.7 requires a peer of es6-promise@^3.0.2 but none was installed.
npm WARN angular2@2.0.0-beta.7 requires a peer of es6-shim@^0.33.3 but none was installed.
npm WARN angular2@2.0.0-beta.7 requires a peer of reflect-metadata@0.1.2 but none was installed.
npm WARN angular2@2.0.0-beta.7 requires a peer of rxjs@5.0.0-beta.2 but none was installed.
npm WARN angular2@2.0.0-beta.7 requires a peer of zone.js@0.5.15 but none was installed.

Неужели нужно вручную устанавливать все пакеты?
  • Вопрос задан
  • 6773 просмотра
Пригласить эксперта
Ответы на вопрос 2
pomeo
@pomeo
Они не обязательные. Если вам не нужен < IE11, зачем вам es6-promise например
Ответ написан
Да, вручную. Или как предлагается в туториале angular 2 - брать их package.json и просто делать npm install
https://angular.io/docs/js/latest/quickstart.html#...
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы