r3st1k25
@r3st1k25
Senior PHPomidor

Почему php -v показывает старую версию?

В настройках OpenServer поставил PHP 5.6. Зайдя в PHPInfo выдает 5.6.3. При использовании Laravel 5 есть такая ошибка
Problem 1
    - This package requires php >=5.5.9 but your PHP version (5.4.35) does not satisfy that requirement.

Прописал в консольке php -v . Выдало версию 5.4.35, хотя в настройках и PHPInfo стоит 5.6.3! Помогите, пол дня уничтожено..
  • Вопрос задан
  • 836 просмотров
Пригласить эксперта
Ответы на вопрос 3
@makenow
Ещё бывает так, что у вас установлен Composer, и при установке он требует указать с какой версией php его ассоциировать, и соответственно делает эту версию глобальной. Т.е. при смене версии php, следует также переустановить composer.. (так было у меня. windows 10 + openserver)
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
ToBe Москва
от 250 000 до 300 000 ₽
AMICUM Кемерово
от 80 000 ₽
RecruitIT Москва
от 100 000 до 160 000 ₽
31 окт. 2020, в 18:06
15000 руб./за проект
31 окт. 2020, в 17:52
270000 руб./за проект
31 окт. 2020, в 17:10
3000 руб./за проект