chumayu
@chumayu
Если в башне по*бень. То что еб*нь, что не еб*нь.

Как начинали изучать скрипты Mikrotik?

Оборудование нравится, но хотелось бы углубится в скрипты (на данный момент целей нет, просто для хорошего понимания).

Сообственно вопрос с чего/как лучше начать знакомство со скриптами, начать с wiki.mikrotik.com или возможно есть сайт ресурс посвященный этой тематике?

Интересует личный опыт.
  • Вопрос задан
  • 2677 просмотров
Решения вопроса 1
LESHIY_ODESSA
@LESHIY_ODESSA
Самый эффективный способ это находить чужие скрипты и разбирать их построчно. Само собою перед этим 2-3 раза перечитать wiki/Manual:Scripting.

Я далеко не с програмисткими мозгами написал скрипт для FreeDNS.afraid.org. Ушло у меня на это несколько дней. Уйма часов. Люди с программистским складом ума сделали бы тоже самое 20-30 минут.

Вот мои заметки.

Для отладки :
put – выводит значение переменной,
$ - означает, что это переменная,
gvar – имя переменной. (ЛЮБОЕ)
:put $gvar;
узнаем IP домена
:put [:resolve www.google.com]

получаем текущий IP WAN интерфейса
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]


удаляем файлы по части названия файла

:foreach i in=[/file find] do={:if ([:typeof [:find [/file get $i name] "НАЗВАНИЕ"]]!="nil") do={/file remove $i}}


Ссылки :
Простые примеры от разработчиков RouterOS
Скрипты, добавленные пользователями

Писать скрипты для Mikrotik RouterOS — это просто

MikroTik — автоматически выключаем и включаем WiFi...
MikroTik — Автоматически меняем MAC адрес на рандомный
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
dimonchik2013
@dimonchik2013
добавлять ли масло в тарталетки с черной икрой?
ресурс - сам микротик, с модерируемыми постами на форуме

ну и на сайтах про сети есть немало авторских статей
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы