getNullData
@getNullData

OS X Проблемы с PHP версиями, как решить?

Добрый вечер.
При помощи brew поставил себе Apache2, PHP 5.6.12, php-xdebug .. etc.
Запускаю проект и понимаю что то не так.
Решил запустить phpinfo(), как оказалось, сайт работает на PHP Version 5.5.27 и ни какой речи о xdebug.
Но я ведь ставил PHP Version 5.6.12.
Если посмотреть в консоли, то получим следующие:
$ php -v
PHP 5.6.12 (cli) (built: Sep  5 2015 20:54:18) (DEBUG)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
    with Xdebug v2.3.3, Copyright (c) 2002-2015, by Derick Rethans
sayber at iMac-sayber in ~
$ php -m | grep xdebug
xdebug


Т.е. все нормально.
Открыл процессы по htop, там работает из PHP только php-fpm из директории 5.6.12.

Вопрос: PHP 5.5.27 в Yosemite 10.10.5 идет из коробки, но как от него избавиться и заставить работать 5.6 ?

В apache httpd.conf ставил
LoadModule php5_module libexec/apache2/libphp5.so
  • Вопрос задан
  • 168 просмотров
Решения вопроса 2
DevMan
@DevMan Куратор тега PHP
так у вас апач грузит дефолтный модуль, укажите путь к своему.
как-то типа:
LoadModule php5_module /usr/local/opt/php56/libexec/apache2/libphp5.so
Ответ написан
sayber
@sayber Куратор тега PHP
Да, я программирую на PHP и еще асинхронно!
Может стоит в apache указать ?
LoadModule php5_module /usr/local/Cellar/php56/5.6.12/libexec/apache2/libphp5.so
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
07 мар. 2021, в 03:18
1500 руб./за проект
06 мар. 2021, в 22:58
70000 руб./за проект
06 мар. 2021, в 22:36
10000 руб./за проект