Как вы ставите модули в Python? Как поставить этот?

Некоторые ставятся как по маслу (вроде BeautifulSoup), а некоторые вот так:

d8a3f1386eb74b6baaf9092a37a4a21b.png

модуль newspaper. Ставлю с правами админа, python 3.4: C:\python34\scripts\pip install newspaper
newspaper.readthedocs.org/en/latest/user_guide/ins...
https://github.com/codelucas/newspaper

Второй день на питоне - теряюсь как и что
  • Вопрос задан
  • 1907 просмотров
Решения вопроса 1
dimonchik2013
@dimonchik2013
...встаю, одеваюсь, завтракаю и еду домой...
1) ставить рекомендую из PyCharm, в целом все то же самое, зависимости он тоже подтягивает, но устроено посимпатичнее (например на 2.7 32bit этот newspaper поставился без вопросов одним кликом)

2) некоторые модули зависят от других модулей, и, конечно, скачивают их при установке через pip, но не всегда могут поставить. Тогда нужно смотреть в логи и ставить эти зависимости вручную/непосредственно (тоже из PyCharm, но разбирать индивидуально, почему какая не поставилась - например, не скачалась или еще что)

3) и, наконец, и зависимости из п.2 и сами модули могут зависить от компиляции C++ ного кода. Тут, как правило, будет засада: иногда он сходу-то и под Linux не собирается ( потому что уже в C++ коде есть зависимости, разрядность та же)), ну а под Windows совсем мрачно: тут на помощь приходят готовые инсталляторы, которые уже содержат скомпилированные Dll ки, ставятся они инсталлером, как правило, и после установки вполне себе видны в PyCharm, после чего можно смело ставить зависящие от них.

Исходя из п.3 вы должны понимать, что шансы поставить модуль, зависящий от Сишного кода, прямо пропорциональны Вашему умению пользоваться Гуглом или Вашему опыту в C компилировании. Говоря проще - если инсталлятор не найдете - поставить нереально.

Например, PyCurl для 64 битной винды существует только версии 7.19, а последний - 7.19.5, разница на деле огромна - последний поддерживает уникод, а первый нет, в итоге не работает нормально, например, GrabLib. Также практически нет под третий питон некоторых старых компилирующихся (по-моему, SciPy только под 2,7 и т.п.). Также под Винду просто нет некоторых новомодных, например, aiohttp (этот может и есть, но вот связанных с ним точно нет, т.е. особо с асихроном не поиграете). Популярный lxml отсутствует под 64 бита и т.д.

Поэтому использовать Linux вам придется. Оригинально "совместимость" решают в Kivy - под Винду дают скачать виртуалку с Линуксом. Можетее от нее и оттолкнуться, разрядность только проверьте.

Примерно так же пишет/рассказывает автор Python the hard way - у него в первых уроках ставится Виртуалка, и дальше все на ней.

Но! Не забывайте, что Python это и GUI приложения ( и игры), а их аудитория живет на Windows, поэтому проблему нужно знать со всех сторон, и отказываться от Windows ("я поставил Линук и все пофиг") нельзя.
Ответ написан
Пригласить эксперта
Ответы на вопрос 2
chinskiy
@chinskiy
Лучше поставь линукс, и проблемы с установкой пакетов исчезнут.
Ставить пакеты на windows - не благодарное дело(
Ответ написан
nextel
@nextel
ненавижу javascript
ТАм целый зоопарк зависимостей, вы их все поставили?
ыам стектрейс вывалил importerror это значит что невозможно подключить ммождуль(считай нет его в системе или найти не может), а это значит проверяйте все зависимости и пути до них
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
26 февр. 2020, в 01:14
600 руб./в час
26 февр. 2020, в 01:13
1500 руб./за проект
25 февр. 2020, в 23:26
100000 руб./за проект