kellas
@kellas
веб-разработчик

Почему может регулярно отваливаться ppoe-соединение?

На роутере tplink TL-WR741ND (ver. 4.2), с прошивкой OpenWrt 12.09-rc1 регулярно отваливается ppoe-соединение.
Это началось после перехода моего провайдера "ВБТ"(Калининград) на сети "Голден телеком"(Билайн).
Если подключиться напрямую с ПК(linux ubuntu) - интернет есть.

Вот конфиг сети с роутера /etc/config/network
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'eth0'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config interface 'wan3'
	option proto 'pppoe'
	option password 'kel****'
	option ifname 'eth1'
	option username 'alexstep'
	option demand '0'

config switch
	option name 'eth0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'eth0'
	option vlan '1'
	option ports '0 1 2 3 4'


Соединение wan на роутере регуляно отваливается и не хочет подключаться, ребут роутера не помогает.

А помогает что интересно переименовывание интерфейса wan, например в wan2. После чего это же соединение с новым именем работает.

Wan2 опять через время зависает, переименовываю обратно в wan либо wan3 либо во что угодно другое и снова коннект есть.
Вот такое причудливое поведение.

Есть идеи, что это и почему?
Вот что выдаёт dmesg сразу после "падения".
[   20.370000] br-lan: port 1(eth0) entered forwarding state
[   20.970000] eth1: link up (100Mbps/Half duplex)
[   21.730000] device wlan0 entered promiscuous mode
[   22.090000] br-lan: port 2(wlan0) entered forwarding state
[   22.100000] br-lan: port 2(wlan0) entered forwarding state
[   24.100000] br-lan: port 2(wlan0) entered forwarding state
[   77.070000] eth1: link down
[   78.030000] eth1: link up (100Mbps/Half duplex)
[ 2128.010000] ------------[ cut here ]------------
[ 2128.010000] WARNING: at net/sched/sch_generic.c:256 0x802011b0()
[ 2128.010000] NETDEV WATCHDOG: eth1 (ag71xx): transmit queue 0 timed out
[ 2128.020000] Modules linked in: ath79_wdt ohci_hcd ledtrig_usbdev ledtrig_netdev nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat pppoe xt_conntrack xt_CT xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ehci_hcd pppox ipt_REJECT xt_TCPMSS ipt_LOG xt_comment xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables ppp_async ppp_generic slhc ath9k(O) ath9k_common(O) ath9k_hw(O) ath(O) mac80211(O) usbcore usb_common nls_base crc_ccitt cfg80211(O) compat(O) arc4 aes_generic crypto_algapi ledtrig_timer ledtrig_default_on leds_gpio gpio_button_hotplug(O)
[ 2128.080000] Call Trace:[<80283918>] 0x80283918
[ 2128.080000] [<80283918>] 0x80283918
[ 2128.090000] [<8007198c>] 0x8007198c
[ 2128.090000] [<802011b0>] 0x802011b0
[ 2128.090000] [<80071a40>] 0x80071a40
[ 2128.100000] [<802011b0>] 0x802011b0
[ 2128.100000] [<80201040>] 0x80201040
[ 2128.100000] [<8007c4ac>] 0x8007c4ac
[ 2128.110000] [<80076fb8>] 0x80076fb8
[ 2128.110000] [<800771c8>] 0x800771c8
[ 2128.110000] [<800e6188>] 0x800e6188
[ 2128.120000] [<800773fc>] 0x800773fc
[ 2128.120000] [<8006306c>] 0x8006306c
[ 2128.120000] 
[ 2128.130000] ---[ end trace 512fd51e622e6e05 ]---
[ 2128.130000] eth1: tx timeout
[ 2128.130000] eth1: link down
[ 2128.140000] eth1: link up (100Mbps/Half duplex)
[ 2138.010000] eth1: tx timeout
[ 2138.010000] eth1: link down

Вот на всякий случай архив со всеми конфигами.
  • Вопрос задан
  • 1284 просмотра
Пригласить эксперта
Ответы на вопрос 2
Scorpi
@Scorpi
Похоже ваш случай: https://dev.openwrt.org/ticket/6754
Ответ написан
Комментировать
kellas
@kellas Автор вопроса
веб-разработчик
Поменял логин на alexstep@wbt, сутки полёт нормальный.
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы