shaivam
@shaivam

Обновление до jessie — как заставить работать remmina?

после замены в источникак визи на джесси следующая проблема при попытке обновиться.
Недели 2 назад зашёл на домашнем ноуте в дебиан джесси, в который уже пол года не заходил, - обновился, попытался поставить remmina - фиг там, на libjpeg62 ругался, из за этого плагин rdp - основной, который мне нужен не встал. Честно подумал, что я устроил помойку из пакетов из разных реп, поэтому проблема с это библиотекой. Затёр, поставил чистую визи - ремина встала, всё работает без проблем. Теперь вижу, что проблема не из за пакетопомойки была.....
итак, что говорит aptitude dist-upgrade (конец вывода)
Следующие пакеты имеют неудовлетворённые зависимости:
xserver-xorg-video-rendition : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
xserver-xorg-video-s3virge : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
gcc-4.9-base : Ломает: gcc-4.7-base (< 4.7.3) но установлен 4.7.2-5
xserver-xorg-video-apm : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
xserver-xorg-video-ark : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
libgpod4-nogtk : Конфликтует: libgpod4 но устанавливается 0.8.3-1.1+b1.
libjpeg62-turbo : Конфликтует: libjpeg62 но установлен 6b1-3+deb7u1
xserver-xorg-video-sis : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
cups-filters : Конфликтует: foomatic-filters но устанавливается 4.0.17-5.
Конфликтует: ghostscript-cups но установлен 9.05~dfsg-6.3+deb7u1
tk : Ломает: tk8.4 (< 8.4.20-2) но установлен 8.4.19-5
xserver-xorg-video-s3 : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
libgpod4 : Конфликтует: libgpod4-nogtk но устанавливается 0.8.3-1.1+b1.
xserver-xorg-video-tseng : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
python-gi : Ломает: software-center (<= 5.6.0-0ubuntu2) но установлен 5.1.2debian3.1
libtcl8.6 : Ломает: tcl8.4 (< 8.4.20-2) но установлен 8.4.19-5
Ломает: tk8.4 (< 8.4.20-2) но установлен 8.4.19-5
tcl : Ломает: tcl8.4 (< 8.4.20-2) но установлен 8.4.19-5
packagekit : Ломает: packagekit-backend-aptcc (< 1.0) но установлен 0.7.6-3
xserver-xorg-video-i128 : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
xserver-xorg-video-chips : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
xserver-xorg-video-voodoo : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
xserver-xorg-video-i740 : Зависит: xorg-video-abi-12 который является виртуальным пакетом.
db5.1-util : Ломает: libdb5.1 (< 5.1.29-8~) но установлен 5.1.29-5
Следующие действия разрешат зависимости:

Удалить следующие пакеты:
1) db5.1-util
2) foomatic-filters
3) gcc-4.7-base
4) ghostscript-cups
5) libgpod4-nogtk
6) libjpeg62
7) software-center
8) update-notifier
9) xserver-xorg-video-apm
10) xserver-xorg-video-ark
11) xserver-xorg-video-chips
12) xserver-xorg-video-i128
13) xserver-xorg-video-i740
14) xserver-xorg-video-rendition
15) xserver-xorg-video-s3
16) xserver-xorg-video-s3virge
17) xserver-xorg-video-sis
18) xserver-xorg-video-tseng
19) xserver-xorg-video-voodoo

Сохранить для следующих пакетов их текущие версии:
20) gnome-packagekit [Не установлен]
21) gnome-packagekit-session [Не установлен]
22) libtcl8.6 [Не установлен]
23) libtk8.6 [Не установлен]
24) packagekit [Не установлен]
25) packagekit-tools [Не установлен]
26) tcl [Не установлен]
27) tcl8.6 [Не установлен]
28) tk [Не установлен]
29) tk8.6 [Не установлен]

Оставить следующие зависимости неразрешёнными:
30) printer-driver-foo2zjs-common рекомендует tk
31) libpackagekit-glib2-18 рекомендует packagekit (= 1.0.1-2)
32) software-center рекомендует update-notifier

Принять данное решение? [Y/n/q/?] n
  • Вопрос задан
  • 627 просмотров
Решения вопроса 1
shaivam
@shaivam Автор вопроса
UPD: оказывается, aptitude давно "не в моде"(заброшен). Видимо им я и убил предыдущую джесси. Проблема решилась использованием apt-get
Ответ написан
Пригласить эксперта
Ответы на вопрос 1
@AVKor
оказывается, aptitude давно "не в моде"(заброшен)

wheezy (stable): 0.6.8.2-1
jessie (testing): 0.6.11-1+b1
Просто голову не надо слишком далеко забрасывать.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы