MToUCH
@MToUCH
Сетевой инженер

Как исправить конфликт JS-скриптов в drupal 7?

Чтобы bootstrap корректно работал, мне понадобилось указать более новую версию JS. Старая 1.4.4.
Я ставил модуль jQuery Update и выставил настройки так (на картинке ниже):

745ed36dd8804fc199935caa8bad3702.png

Получается, что под админом должен работать скрипт 1.10, но когда я захожу в редактирование страницы, загрузку изображения, окно загрузки изображения показывает что подключен скрипт 1.10, а мне нужен там дефолтный. Из за этого не работают кнопки загрузки в верхней строке:

681de86f289749ce90de54731b2c0af2.png

Редактор Tiny_MCE.
Подскажите, пожалуйста, как быть? Хотя бы как для этого окна персонально выставить скрипт, если не кардинально исправить другие возможные ошибки?!
  • Вопрос задан
  • 609 просмотров
Решения вопроса 1
drupby
@drupby
Если внимательно присмотреться к исходному коду, то будет видно что файловый браузер грузится в iframe, а у него урл /imce, который естественно не административный. Поэтому нужно написать небольшой модуль и туда вставить код

/**
 * Implements hook_admin_paths().
 *
 * Add IMCE to admin paths.
 */
function mymodule_admin_paths() {
  $paths = array(
    'imce' => TRUE,
  );
  return $paths;
}
Ответ написан
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы