KEugene
@KEugene

Как правильно настроить Lua в VSCode?

Добрый день.
Подскажите, пожалуйста, как настроить полностью настроить Lua в VSCode?
На компьютере Win11 x64 установлена Visual Studio Code v. 1.78.2.
В качестве плагинов стоят
  • lua-language-server
  • Lua snippets
  • lua-debug
  • LuaHelper Guide
  • glua

Скрипты запускаются без проблем. Но любое взаимодействие с чем-то внешним приводит к ошибке. В принципе, сама команда require не работает
require: The term 'require' is not recognized as a name of a cmdlet, function, script file, or executable program.

Как настроить/устанавливать внешние плагины? Это относится как к менеджеру пакетов LuaRocks, так и к автономным пакетам, например "ui".
Может, есть ссылка на готовый материал... То, что я нашел в интернете относится к установке/настройке Lua в качестве независимой программы, к которой подключается VSCode, но я бы хотел, при возможности, не захламлять систему.
Спасибо.

UPD
Я разобрался, где можно держать дополнительные библиотеки. Но я так и не нашел, куда (наименование параметра) и какой путь прописать в настройках (сервера и/или отладчика), чтобы начали работать стандартные библиотеки.

UPD 2
Честно говоря, я забил на это дело. Поставил ZeroBrane Studio и все заработало "из коробки". У них в последнем дистрибутиве стоит версия 5.3 (хотя пишут, что должна быть 5.4). Чтобы добавить вручную 5.4 потребовалось еще 10 минут.
  • Вопрос задан
  • 1816 просмотров
Пригласить эксперта
Ответы на вопрос 1
PhoenixX33i
@PhoenixX33i
Для подсветки синтаксиса и автодополнений можно выбрать между LuaHelper и Lua. Они, на мой взгляд, наиболее адекватные. Все можете увидеть сами на странице расширения, описания там краткое - займет пару минут.
Для комфортной отладки кода - Local Lua Debugger. Требует только установить Lua локально (самому) и указать путь к ней в настройках расширения.
Ответ написан
Комментировать
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы