Поставить полного клиента Oracle 19.3 на SUSE Tumbleweed?

Понадобилось поставить полного клиента на TW, т.к. инстант формально не поддерживается приложением.

Предварительная проверка требует набора библиотек, которые в дефолтных репозиторих не находятся, а подключение OLES репозитория ругается на конфликты чуть не на каждой требуемой библиотеке

The following NEW package is going to be installed:
  elfutils-libelf

1 new package to install.
Overall download size: 0 B. Already cached: 231.0 KiB. After the operation, additional 999.5 KiB will be used.
Continue? [y/n/v/...? shows all options] (y): y
In cache elfutils-libelf-0.187-4.el8.x86_64.rpm                                                                                                                        (1/1), 231.0 KiB (999.5 KiB unpacked)

Checking for file conflicts: ...................................................................................[error]
Detected 1 file conflict:

File /usr/lib64/libelf.so.1
  from install of
     elfutils-libelf-0.187-4.el8.x86_64 (OL8)
  conflicts with file from package
     libelf1-0.189-3.1.x86_64 (@System)


Как поступить в таком случае? Игнорировать требования инсталятора, которые не удалось решить без конфликтов?

На SLES/Leap такая же картина будет?

И еще, отчего-то предпроверка требует и кучи 32-битных пакетов (причем часть 32bit...x86_64) - они-то зачем?
6464d54d643fb382845715.jpeg
  • Вопрос задан
  • 136 просмотров
Решения вопроса 1
Lorien_Elf
@Lorien_Elf
Keep calm and drop database
Официально поддерживается только Enterprise:
https://docs.oracle.com/en/database/oracle/oracle-...

Там же и список необходимых пакетов.

Оттуда же про 32 бита:
Note:If you intend to use 32-bit client applications to access 64-bit servers, then you must also install (where available) the latest 32-bit versions of the packages listed in this table.
Ответ написан
Комментировать
Пригласить эксперта
Ответы на вопрос 1
amk4
@amk4 Автор вопроса
Спасибо.
Проигнорировал пакеты с 32-битной разрядностью.
Поставил и на TW.

Только перед ./runInstaller пришлось немного смухлевать - добавить
export CV_ASSUME_DISTID=SUSE15
иначе ругался - не могу понять, что за ОС

И при установке выпала ошибка, в логе инсталятор прервался на:
/usr/bin/ld: cannot find /usr/lib64/libpthread_nonshared.a: No such file or directory

Странно, написано, что она в glibc-devel должна быть...

Пришлось скачать и вручную поставить
compat-libpthread-nonshared-0-150300.3.6.1.x86_64.rpm

После этого клиент стал. И вроде бы даже подключился к базе...
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы