Как исправить ошибку при установке symfony?

Неделю назад всё работало. Сейчас не устанавливается и выводит ошибку.
Как её исправить?

Устанавливаю
composer update symfony/flex --no-plugins --no-scripts
composer require twig
composer require doctrine
composer require doctrine maker
composer require symfony/apache-pack
composer require symfony/asset
composer require maker
composer require symfony/mime
composer require symfony/sendgrid-mailer -W
composer require symfony/mailer
composer require symfony/http-client

Вот содержимое консоли
User@COMPUTER G:\Program Files\OpenServer 5.4.3\domains\symfony.local
$ composer update symfony/flex --no-plugins --no-scripts
Warning: This development build of Composer is over 60 days old. It is recommended to update it by running "r:\modules\php\PHP_8.1\..\..\..\userdata\composer\composer.phar self-update" to get the latest version.
Loading composer repositories with package information
Updating dependencies
Nothing to modify in lock file
Installing dependencies from lock file (including require-dev)
Nothing to install, update or remove
Generating autoload files
26 packages you are using are looking for funding.
Use the `composer fund` command to find out more!
No security vulnerability advisories found

User@COMPUTER G:\Program Files\OpenServer 5.4.3\domains\symfony.local
$ composer require twig doctrine doctrine maker symfony/apache-pack symfony/asset maker symfony/mime symfony/sendgrid-mailer -W symfony/mailer symfony/http-client
Warning: This development build of Composer is over 60 days old. It is recommended to update it by running "r:\modules\php\PHP_8.1\..\..\..\userdata\composer\composer.phar self-update" to get the latest version.
Using version ^1.0 for symfony/twig-pack
Using version ^2.3 for symfony/orm-pack
Using version ^1.48 for symfony/maker-bundle
Using version ^1.0 for symfony/apache-pack
./composer.json has been updated
Running composer update symfony/twig-pack symfony/orm-pack symfony/maker-bundle symfony/apache-pack symfony/asset symfony/mime symfony/sendgrid-mailer symfony/mailer symfony/http-client --with-all-dependencies
Loading composer repositories with package information
Restricting packages listed in "symfony/symfony" to "6.2.*"
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - __root__ 1.0.0+no-version-set conflicts with symfony/symfony v6.2.4.
    - __root__ 1.0.0+no-version-set conflicts with symfony/symfony v6.2.3.
    - __root__ 1.0.0+no-version-set conflicts with symfony/symfony v6.2.2.
    - __root__ 1.0.0+no-version-set conflicts with symfony/symfony v6.2.1.
    - __root__ 1.0.0+no-version-set conflicts with symfony/symfony v6.2.0.
    - __root__ 1.0.0+no-version-set conflicts with symfony/symfony v6.2.0-RC2.
    - __root__ 1.0.0+no-version-set conflicts with symfony/symfony v6.2.0-RC1.
    - __root__ 1.0.0+no-version-set conflicts with symfony/symfony v6.2.0-BETA3.
    - __root__ 1.0.0+no-version-set conflicts with symfony/symfony v6.2.0-BETA2.
    - __root__ 1.0.0+no-version-set conflicts with symfony/symfony v6.2.0-BETA1.
    - __root__ 1.0.0+no-version-set conflicts with symfony/symfony 6.2.x-dev.
    - __root__ is present at version 1.0.0+no-version-set and cannot be modified by Composer
    - Root composer.json requires symfony/dotenv 6.2.* -> satisfiable by symfony/symfony[v6.2.0-BETA1, ..., 6.2.x-dev].

You can also try re-running composer require with an explicit version constraint, e.g. "composer require symfony/twig-pack:*" to figure out if any version is installable, or "composer require symfony/twig-pack:^2.1" if you know which you need.

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

User@COMPUTER G:\Program Files\OpenServer 5.4.3\domains\symfony.local
$

Что тут с чем не совместимо и главное - почему?
Почему разработчики, композер допустил такую ситуацию (не разрешил конфликт сам), и теперь я не могу установить приложение из за несовместимости?

Как исправить эту ошибку?
  • Вопрос задан
  • 347 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы