karuzzo
@karuzzo

Можете расписать данный код по пунктикам?

Добрый день, товарищи.
// Следующий код:

&НаКлиенте
Процедура ОтобратьКонтрагентов(Команда)

АдресВХ = "";
ОтобратьКонтрагентовСервер(АдресВХ);
СтруктураВыбора = Новый Структура;
СтруктураВыбора.Вставить("Контрагенты",АдресВХ);
ОповеститьОВыборе(СтруктураВыбора);
//ЭтаФорма.Закрыть();

КонецПроцедуры

&НаСервере
Процедура ОтобратьКонтрагентовСервер(АдресВХ)

ОбработкаОбъект = РеквизитФормыВЗначение("Объект");
ТаблицаЗначений = Новый ТаблицаЗначений;
СхемаКомпоновкиДанных = ОбработкаОбъект.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
СтруктураПараметров = Новый Структура();
//ПолучитьДанныеНаОснованииСКД(СхемаКомпоновкиДанных, ТаблицаЗначений, КонрагентыСписок.КомпоновщикНастроек.Настройки, СтруктураПараметров);
ПолучитьДанныеНаОснованииСКД(СхемаКомпоновкиДанных, ТаблицаЗначений, Неопределено, СтруктураПараметров);

АдресВХ = ПоместитьВоВременноеХранилище(ТаблицаЗначений,Новый УникальныйИдентификатор());

КонецПроцедуры

//Обработка в другой форме
&НаКлиенте
Процедура КонтрагентыОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
КонтрагентыОбработкаВыбораНаСервере(ВыбранноеЗначение);
СтандартнаяОбработка = Ложь;
КонецПроцедуры

&НаСервере
Процедура КонтрагентыОбработкаВыбораНаСервере(ВыбранноеЗначение)

Если ТипЗнч(ВыбранноеЗначение) = Тип("Структура") Тогда

АдресВХ = ВыбранноеЗначение.Контрагенты;
ТаблицаЗначений = ПолучитьИзВременногоХранилища(АдресВХ);
Объект.Контрагенты.Очистить();
Для каждого Элемент из ТаблицаЗначений Цикл
НоваяСтрока = Объект.Контрагенты.Добавить();
НоваяСтрока.Контрагент = Элемент.Ссылка;
КонецЦикла;

КонецЕсли;

КонецПроцедуры

От того что значат процедуры, что значит информация в скобках.
И как её научиться читать?
  • Вопрос задан
  • 123 просмотра
Решения вопроса 1
fosihas
@fosihas
Автоматизации учета на 1С.
Команда, которая можно вывести как кнопку - ОтобратьКонтрагентов(Команда)

ОтобратьКонтрагентовСервер(АдресВХ);
Она находит макет в котором подготовленный Схема компоновки данных. И кажется формируется Таблица значеним.

отсутвует - ПолучитьДанныеНаОснованииСКД(
https://1cskd.ru/2014/05/poleznye-primery-poluchen...

ОповеститьОВыборе(СтруктураВыбора) - тут почитай что ее техническое описание
она запускает КонтрагентыОбработкаВыбора() в которой

И как её научиться читать?

как книгу с гиперссылками
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
06 дек. 2022, в 20:37
10000 руб./за проект
06 дек. 2022, в 20:31
20000 руб./за проект
06 дек. 2022, в 20:26
2500 руб./за проект