Почему пропадает индекс в ElasticSearch после рестарта docker?

Пропадает индекс в ElasticSearch после рестарта docker.
вот мой конфиг docker-compose.yml.

Чего не хватает чтобы индекс сохранялся?

version: "3.7"
services:
  elastic:
    image: elasticsearch:8.1.0
    ports:
      - "9200:9200"
    environment:
      - xpack.security.enabled=false
      - discovery.type=single-node
      - http.port=9200
      - http.cors.enabled=true
      - http.cors.allow-origin=*
      - http.cors.allow-headers=X-Requested-With,X-Auth-Token,Content-Type,Content-Length,Authorization
      - http.cors.allow-credentials=true
      - bootstrap.memory_lock=true
      - network.publish_host=localhost
      - 'ES_JAVA_OPTS=-Xms750m -Xmx750m'
    volumes:
      - esdata:/usr/share/elasticsearch/data

  elasticAdmin:
    image: appbaseio/dejavu
    ports:
      - "1358:1358"
    links:
      - elastic

  app:
    build: .
    env_file:
      - .env
    volumes:
      - .:/app
    ports:
      - 8081:8080
    depends_on:
      - elastic

volumes:
  esdata:


UPD.

Я наверное, не правильно описал проблему. Индекс есть, просто я не могу из него ничего прочитать до тех пор, пока не запишу что - нибудь в него новое. После этого неожиданно все данные в индексе появляются.
Как будто происходит обновление данных где - то.
  • Вопрос задан
  • 210 просмотров
Пригласить эксперта
Ответы на вопрос 2
@q2digger
никого не трогаю, починяю примус
ну, на первый взгляд volume вроде указан верно, смотрит куда надо. надо копать - смотрите что в логах, может там что есть интересное.
после остановки контейнера volume на месте?
docker volume ls
Ответ написан
@dinya17 Автор вопроса
Всем спасибо. Я отвечаю с запозданием. Все заработало. Это было что - то локальное на машине. Сейчас все ок работает. В докере почистил кучу старых образов и все заработало.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы