@rufusnic

Сломался debian что делать?

у меня debian 11с оболочкой gnome 3.
Я хотел попробовать оболочку mate решил ее установить,
командой
sudo apt install mate-desktop-environment-extras
но выдало ошибку:
Следующие пакеты имеют неудовлетворённые зависимости:
libgail-3-0 : Зависит: libgtk-3-0 (= 3.24.5-1) но 3.24.24-4+deb11u2 должен быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

по шел искать ответ на просторах интернета, набрел на этот сайт: https://losst.ru/oshibka-u-vas-zafiksirovany-sloma... все выполнил по инструкции, но при вводе команды sudo apt update --fix-missing
такой выхлоп-
mike@debian:~$ sudo apt update --fix-missing
Сущ:1 mirror.truenetwork.ru/debian bullseye-updates InRelease
Игн:2 ftp.debian.org/debian jessie InRelease
Сущ:3 security.debian.org/debian-security bullseye-security InRelease
Сущ:4 ftp.debian.org/debian oldstable InRelease
Пол:5 ftp.debian.org/debian jessie Release [77,3 kB]
Игн:6 ppa.launchpad.net/teejee2008/ppa/ubuntu kinetic InRelease
Пол:7 ftp.debian.org/debian jessie Release.gpg [1 652 B]
Игн:7 ftp.debian.org/debian jessie Release.gpg
Пол:8 ppa.launchpad.net/git-core/ppa/ubuntu kinetic InRelease [23,8 kB]
Ошб:8 ppa.launchpad.net/git-core/ppa/ubuntu kinetic InRelease
Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY A1715D88E1DF1F24
Ошб:9 ppa.launchpad.net/teejee2008/ppa/ubuntu kinetic Release
404 Not Found [IP: 185.125.190.52 80]
Чтение списков пакетов… Готово
W: Ошибка GPG: ftp.debian.org/debian jessie Release: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY 7638D0442B90D010 NO_PUBKEY CBF8D6FD518E17E1
E: Репозиторий «ftp.debian.org/debian jessie Release» не подписан.
N: Обновление из этого репозитория нельзя выполнить безопасным способом, поэтому по умолчанию он отключён.
N: Информацию о создании репозитория и настройках пользователя смотрите в справочной странице apt-secure(8).
W: Ошибка GPG: ppa.launchpad.net/git-core/ppa/ubuntu kinetic InRelease: Следующие подписи не могут быть проверены, так как недоступен открытый ключ: NO_PUBKEY A1715D88E1DF1F24
E: Репозиторий «ppa.launchpad.net/git-core/ppa/ubuntu kinetic InRelease» не подписан.
N: Обновление из этого репозитория нельзя выполнить безопасным способом, поэтому по умолчанию он отключён.
N: Информацию о создании репозитория и настройках пользователя смотрите в справочной странице apt-secure(8).
E: Репозиторий «ppa.launchpad.net/teejee2008/ppa/ubuntu kinetic Release» не содержит файла Release.
N: Обновление из этого репозитория нельзя выполнить безопасным способом, поэтому по умолчанию он отключён.
N: Информацию о создании репозитория и настройках пользователя смотрите в справочной странице apt-secure(8).
mike@debian:~$

ничего не помогло, остались все теже ошибки
  • Вопрос задан
  • 627 просмотров
Решения вопроса 2
@AVKor
Причина всегда одна и та же. И решение тоже. Не надо ставить в источники пакетов всякий шлак, набранный из "туториалов".
Ответ написан
noostyche
@noostyche
Game developer
PPA репозитории от Ubuntu... Серьёзно? Удаляй все пакеты, что были поставлены из этих PPA, затем:
sudo apt-get -f install

При этом очень вримательно ознакомиться с тем, что предлагает установить-удалить.
Ответ написан
Пригласить эксперта
Ответы на вопрос 2
@bad_dab_bad
Для начала:
sudo apt update --allow-unauthenticated --fix-missing
Но на свой страх и риск.
А вообще сломанные зависимости - это адская боль.
Ответ написан
sotvm
@sotvm
Умный поймёт, а дураку и так всё равно.
ставьте мета-пакет и не ломайте голову
это раньше цена 1МБ на диске, стоила как мерседес,
сейчас это уже не актуально
под линух мне хватает 120 гб ssd за глаза,
даже с учётом пару виртуалок и винды на них ))
зы
как по мне = проще/быстрее накатить новую систему,
Но если основные настройки хомяка у вас есть
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы