@Eitewi

Как создать проект laravel php?

впервые создаю проект laravel,
как собственно включить
To enable extensions, verify that they are enabled in your .ini
из ошибки
C:\Users\admin\Desktop\php_first>composer create-project laravel/laravel
Creating a "laravel/laravel" project at "./laravel"
Info from https://repo.packagist.org: #StandWithUkraine
Installing laravel/laravel (v9.1.10)
  - Installing laravel/laravel (v9.1.10): Extracting archive
Created project in C:\Users\admin\Desktop\php_first\laravel
> @php -r "file_exists('.env') || copy('.env.example', '.env');"
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - laravel/framework[v9.18.0, ..., 9.x-dev] require league/flysystem ^3.0.16 -> satisfiable by league/flysystem[3.0.16, ..., 3.x-dev].     
    - laravel/framework[v9.11.0, ..., v9.17.0] require league/flysystem ^3.0 -> satisfiable by league/flysystem[3.0.0, ..., 3.x-dev].
    - league/flysystem[3.0.0, ..., 3.x-dev] require league/mime-type-detection ^1.0.0 -> satisfiable by league/mime-type-detection[1.0.0, ..., 1.11.0].
    - league/mime-type-detection[1.0.0, ..., 1.3.0] require php ^7.2 -> your php version (8.1.7) does not satisfy that requirement.
    - league/mime-type-detection[1.4.0, ..., 1.11.0] require ext-fileinfo * -> it is missing from your system. Install or enable PHP's fileinfo extension.
    - Root composer.json requires laravel/framework ^9.11 -> satisfiable by laravel/framework[v9.11.0, ..., 9.x-dev].

To enable extensions, verify that they are enabled in your .ini files:
    - E:\Services\php\php.ini
You can also run `php --ini` in a terminal to see which files are used by PHP in CLI mode.
Alternatively, you can run Composer with `--ignore-platform-req=ext-fileinfo` to temporarily ignore these required extensions.
  • Вопрос задан
  • 121 просмотр
Пригласить эксперта
Ответы на вопрос 2
@tukreb
Читаем внимательно ошибку, чтобы запустить проект. Если вы не способны понять ошибку, вас надо гнать поганой метлой из программирования.
+ решение проблемы так же легко гуглится, если у вас огромные проблемы с чтением ошибок.
Ответ написан
Комментировать
@sl0
Основных ошибок тут две:
1.
require php ^7.2 -> your php version (8.1.7) does not satisfy that requirement.

2.
require ext-fileinfo * -> it is missing from your system. Install or enable PHP's fileinfo extension.


Т.е. нужно привести php к нужной версии и в php.ini добавить/расскоментировать
extension=fileinfo

Но вообще, разрабатывая на винде таким образом - проблемы будут валиться одна за другой. Советую посмотреть в сторону wsl. Поначалу может быть сложно, но в будущем сильно пригодится. Особенно, когда придется перейти на докер. А придется.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы