Как исправить ошибку downgrade php в centos7?

Собственно заказчик спохватился и попросил откатиться.
я не долго думаю делаю следующий ход конем
yum --disablerepo=remi-php74
yum --enablerepo=remi-php71 downgrade php php-*
Но нет, вылезает ошибка

...
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:7.1.33-19.el7.remi will be a downgrade
--> Processing Dependency: php-common(x86-64) = 7.1.33-19.el7.remi for package: php-7.1.33-19.el7.remi.x86_64
---> Package php.x86_64 0:7.4.29-1.el7.remi will be erased
---> Package php-cli.x86_64 0:7.1.33-19.el7.remi will be a downgrade
--> Processing Dependency: php-common(x86-64) = 7.1.33-19.el7.remi for package: php-cli-7.1.33-19.el7.remi.x86_64
---> Package php-cli.x86_64 0:7.4.29-1.el7.remi will be erased
--> Finished Dependency Resolution
Error: Package: php-7.1.33-19.el7.remi.x86_64 (remi-php71)
           Requires: php-common(x86-64) = 7.1.33-19.el7.remi
           Installed: php-common-7.4.29-1.el7.remi.x86_64 (@remi-php74)
               php-common(x86-64) = 7.4.29-1.el7.remi
           Available: php-common-5.4.16-48.el7.x86_64 (base)
               php-common(x86-64) = 5.4.16-48.el7
  • Вопрос задан
  • 56 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы