@CenterJoin

Ошибка профилировщика при апгрейде symfony 4.4 to 5.4?

При обновлении symfony 4.4 to 5.4 возникла проблема с профилировщиком:
/_wdt/ad0ede 404 (Not Found)
composer:
"require": {
        "php": "^8.0",
        "ext-exif": "*",
        "ext-gd": "*",
        "ext-json": "*",
        "aws/aws-sdk-php": "^3",
        "babdev/pagerfanta-bundle": "^3.6",
        "jms/serializer-bundle": "^4.0.2",
        "knplabs/knp-gaufrette-bundle": "v0.7.2",
        "knplabs/knp-snappy-bundle": "1.7.*",
        "lexik/jwt-authentication-bundle": "^2.6",
        "liip/imagine-bundle": "^2.7",
        "nelmio/api-doc-bundle": "3.*",
        "nelmio/cors-bundle": "^2.0.0",
        "phpoffice/phpspreadsheet": "^1.6",
        "pomm-project/cli": "2.0.3",
        "pomm-project/pomm-bundle": "3.0.0",
        "robmorgan/phinx": "^0.12",
        "sensio/framework-extra-bundle": "v6.0.0",
        "symfony/apache-pack": "^1.0",
        "symfony/console": "5.4.*",
        "symfony/dependency-injection": "5.4.*",
        "symfony/form": "5.4.*",
        "symfony/framework-bundle": "5.4.*",
        "symfony/http-foundation": "5.4.*",
        "symfony/mailer": "5.4.*",
        "symfony/phpunit-bridge": "5.4.*",
        "symfony/polyfill-ctype": "^1.25",
        "symfony/runtime": "5.4.*",
        "symfony/templating": "5.4.*",
        "symfony/translation": "5.4.*",
        "symfony/twig-bridge": "5.4.*",
        "symfony/twig-bundle": "5.4.*",
        "symfony/validator": "5.4.*",
        "symfony/yaml": "5.4.*",
        "twig/twig": "^2.13",
        "willdurand/hateoas-bundle": "^2.4.0"
    },
    "require-dev": {
        "friendsofphp/php-cs-fixer": "v3.8.0",
        "phpunit/phpunit": "9.*",
        "symfony/asset": "5.4.*",
        "symfony/browser-kit": "5.4.*",
        "symfony/dotenv": "5.4.*",
        "symfony/flex": "2.1.*",
        "symfony/monolog-bundle": "3.7.*",
        "symfony/stopwatch": "5.4.*",
        "symfony/web-profiler-bundle": "5.4.*"
    },
    "config": {
        "preferred-install": {
            "*": "dist"
        },
        "sort-packages": true
    },
    "autoload": {
        "psr-4": {
            "App\\": "src/"
        }
    },
    "autoload-dev": {
        "psr-4": {
            "App\\Tests\\": "tests/"
        }
    },
    "replace": {
        "symfony/polyfill-iconv": "*",
        "symfony/polyfill-php70": "*",
        "symfony/polyfill-php56": "*"
    },
    "conflict": {
        "symfony/symfony": "*"
    },
    "extra": {
        "symfony": {
            "id": "01C30AB3TWDAZ4KA0Q94TGXQMQ",
            "allow-contrib": false,
            "require": "5.4.*"
        }
    },
    "scripts": {
        "auto-scripts": {
            "cache:clear": "symfony-cmd",
            "assets:install %PUBLIC_DIR%": "symfony-cmd"
        }
    }


log
request.INFO: Matched route "_wdt". {"route":"_wdt","route_parameters":{"_route":"_wdt","_controller":"web_profiler.controller.profiler::toolbarAction","token":"9da155"},"request_uri":"http://www.site.loc/_wdt/9da155","method":"GET"}
  • Вопрос задан
  • 102 просмотра
Пригласить эксперта
Ответы на вопрос 1
@tukreb
При обновление нужно выполнить все пункты
https://symfony.com/doc/4.4/setup/upgrade_major.html

После прочитать на github все changelogs в который написаны что было задепрекейчено, что удалено и обновить свой код.

П.С Я обновлял проект в таком порядке 4.4 -> 5.1 -> 5.3 -> 5.4 вычищая код на каждом этапе.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы