Как обновить Bootstrap?

Добрый день! Подскажите как обновиться с Bootstrap 3 до Bootstrap 5.
в composer.json
"require": {
        "php": ">=5.6.0",
        "yiisoft/yii2": ">=2.0.43",
        "yiisoft/yii2-swiftmailer": "~2.0.0 || ~2.1.0",
        "yiisoft/yii2-bootstrap5": ">=1.0",
        "bower-asset/bootstrap": ">=5.1.0"
    },
    "require-dev": {
        "yiisoft/yii2-debug": "~2.1.0",
        "yiisoft/yii2-gii": "~2.1.0",
        "yiisoft/yii2-faker": "~2.0.0",
        "codeception/codeception": "^4.0",
        "codeception/verify": "~0.5.0 || ~1.1.0",
        "codeception/specify": "~0.4.6",
        "symfony/browser-kit": ">=2.7 <=4.2.4",
        "codeception/module-filesystem": "^1.0.0",
        "codeception/module-yii2": "^1.0.0",
        "codeception/module-asserts": "^1.0.0",
        "phpunit/phpunit": ">=6.5.14",
        "yiisoft/yii2-coding-standards": "~2.0"
    },


делаю composer -W update и получаю следующее


Your requirements could not be resolved to an installable set of packages.

Problem 1
- Root composer.json requires bower-asset/bootstrap >=5.1.0, it is found bower-asset/bootstrap[v5.1.0] in the lock file and bower-asset/bootstrap[dev-gs-use-scrollspy-on-docs-table_of_contents, ..., dev-playground, v1.0.0, ..., v1.4.0, v2.0.0, ..., v2.3.2, v3.0.0-RC1, ..., v3.4.1, v4.0.0-alpha1, ..., v4.6.0, v5.0.0-alpha1, ..., v5.0.0-beta3] from composer repo (https://asset-packagist.org) but these do not match your constraint and are therefore not installable. Make sure you either fix the constraint or avoid updating this package to keep the one from the lock file.
Problem 2
- yiisoft/yii2-bootstrap5[2.0.1, ..., 2.0.2] require bower-asset/bootstrap ^5.1.0 -> found bower-asset/bootstrap[v5.1.0] in the lock file and bower-asset/bootstrap[dev-gs-use-scrollspy-on-docs-table_of_contents, ..., dev-playground, v1.0.0, ..., v1.4.0, v2.0.0, ..., v2.3.2, v3.0.0-RC1, ..., v3.4.1, v4.0.0-alpha1, ..., v4.6.0, v5.0.0-alpha1, ..., v5.0.0-beta3] from composer repo (https://asset-packagist.org) but these do not match your constraint and are therefore not installable. Make sure you either fix the constraint or avoid updating this package to keep the one from the lock file.
- Root composer.json requires yiisoft/yii2-bootstrap5 >=1.0 -> satisfiable by yiisoft/yii2-bootstrap5[2.0.1, 2.0.2].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
  • Вопрос задан
  • 133 просмотра
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы