Miheychik
@Miheychik
I'am a robot

Проблема при установке Бота Телеграм на сервер ,как решить?

root@678459-cp29175:~/apk# npm install -g npm
| |---------------------------------------------------------------------------|
WARN engine npm@8.1.0: wanted: {"node":"^12.13.0 || ^14.15.0 || >=16"} (current:                                                                                                              {"node":"8.10.0","npm":"3.5.2"})
WARN engine npm@8.1.0: wanted: {"node":"^12.13.0 || ^14.15.0 || >=16"} (current:                                                                                                             /usr/local/lib
`-- (empty)

npm ERR! Linux 4.15.0-156-generic
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install" "-g" "npm"
npm ERR! node v8.10.0
npm ERR! npm  v3.5.2
npm ERR! path /usr/local/lib/node_modules/.staging/@gar/promisify-ebaab35a
npm ERR! code ENOENT
npm ERR! errno -2
npm ERR! syscall rename

npm ERR! enoent ENOENT: no such file or directory, rename '/usr/local/lib/node_m                                                                                                             odules/.staging/@gar/promisify-ebaab35a' -> '/usr/local/lib/node_modules/npm/nod                                                                                                             e_modules/@gar/promisify'
npm ERR! enoent ENOENT: no such file or directory, rename '/usr/local/lib/node_m                                                                                                             odules/.staging/@gar/promisify-ebaab35a' -> '/usr/local/lib/node_modules/npm/nod                                                                                                             e_modules/@gar/promisify'
npm ERR! enoent This is most likely not a problem with npm itself
npm ERR! enoent and is related to npm not being able to find a file.
npm ERR! enoent

npm ERR! Please include the following file with any support request:
npm ERR!     /root/apk/npm-debug.log
npm ERR! code 1
root@678459-cp29175:~/apk# npm install
loadDep:telegraf -> addNa - |#################################-----------------------------------------------------------------------------------------------------------------------------|
npm ERR! Linux 4.15.0-156-generic
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install"
npm ERR! node v8.10.0
npm ERR! npm  v3.5.2
npm ERR! code EMISSINGARG

npm ERR! typeerror Error: Missing required argument #1
npm ERR! typeerror     at andLogAndFinish (/usr/share/npm/lib/fetch-package-metadata.js:31:3)
npm ERR! typeerror     at fetchPackageMetadata (/usr/share/npm/lib/fetch-package-metadata.js:51:22)
npm ERR! typeerror     at resolveWithNewModule (/usr/share/npm/lib/install/deps.js:456:12)
npm ERR! typeerror     at /usr/share/npm/lib/install/deps.js:457:7
npm ERR! typeerror     at /usr/share/npm/node_modules/iferr/index.js:13:50
npm ERR! typeerror     at /usr/share/npm/lib/fetch-package-metadata.js:37:12
npm ERR! typeerror     at addRequestedAndFinish (/usr/share/npm/lib/fetch-package-metadata.js:82:5)
npm ERR! typeerror     at returnAndAddMetadata (/usr/share/npm/lib/fetch-package-metadata.js:117:7)
npm ERR! typeerror     at pickVersionFromRegistryDocument (/usr/share/npm/lib/fetch-package-metadata.js:134:20)
npm ERR! typeerror     at /usr/share/npm/node_modules/iferr/index.js:13:50
npm ERR! typeerror This is an error with npm itself. Please report this error at:
npm ERR! typeerror     <http://github.com/npm/npm/issues>

npm ERR! Please include the following file with any support request:
npm ERR!     /root/apk/npm-debug.log
  • Вопрос задан
  • 54 просмотра
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы