@alegkonin

Что не так с Ansible?

Привет друг.
Не понимаю в чем проблема, не смог нагуглить.

Playbook:
- 
hosts: "all"
  vars:
    ansible_python_interpreter: /usr/bin/python3
  become: true
  tasks:
  - name: "Install nginx via apt"
    ansible.builtin.apt:
      name: "nginx"
      state: "latest"
      update_cache: true

(тестовый плейбук на простое создание файла проходит успешно)
Авторизация по rsa. в /etc/sudoers на сервере:
<user> ALL=(root:ALL) NOPASSWD:ALL

Вывод ошибки:

TASK [Install nginx via apt] **********************************************************************************************************************************
fatal: [vdska]: FAILED! => {"changed": false, "msg": "Failed to update apt cache: W:Требуется явное подтверждение, прежде чем можно будет обновить данный репозиторий. Дополнительную информацию смотрите в справочной странице apt-secure(8)., E:Репозиторий «http://security.debian.org/debian-security buster/updates InRelease» изменил значение поля «Suite» с «stable» на «oldstable», W:Требуется явное подтверждение, прежде чем можно будет обновить данный репозиторий. Дополнительную информацию смотрите в справочной странице apt-secure(8)., E:Репозиторий «http://deb.debian.org/debian buster InRelease» изменил значение поля «Suite» с «stable» на «oldstable», W:Требуется явное подтверждение, прежде чем можно будет обновить данный репозиторий. Дополнительную информацию смотрите в справочной странице apt-secure(8)., E:Репозиторий «http://deb.debian.org/debian buster-updates InRelease» изменил значение поля «Suite» с «stable-updates» на «oldstable-updates»"}

Как вообще запретить или разрешить менять Suite?
  • Вопрос задан
  • 155 просмотров
Решения вопроса 2
karabanov
@karabanov
Системный администратор
С Ansible всё в порядке.
Состоялся релиз и требуется явное подтверждение на использование нового репазитория.
Чтобы быстро пофиксить можешь зайти на сервер и руками запустить apt update.

Можешь попробовать default_release
-t, --target-release, --default-release
This option controls the default input to the policy engine, it creates a default pin at priority 990 using the specified
release string. This overrides the general settings in /etc/apt/preferences. Specifically pinned packages are not affected by
the value of this option. In short, this option lets you have simple control over which distribution packages will be retrieved
from. Some common examples might be -t '2.1*', -t unstable or -t sid. Configuration Item: APT::Default-Release; see also the
apt_preferences(5) manual page.
Ответ написан
Комментировать
opium
@opium
Просто люблю качественно работать
так у вас репо умер же и перешел в разряд убитых.
тонкий намек что пора бы дебиан обновить или перейти на новый
Ответ написан
Комментировать
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы