@chelnokov_a

Как расширить типы установленной библиотеки?

Добрый день.

Использую swiper. Поставил для него @types/swiper
Однако, как я понял типы описаны не все. Конкретно я получаю такую ошибку.

60f91ab6c1a3d532392519.png

Я попытался переопределить interface AutoplayOptions вот так

interface AutoplayOptions {
    delay: number;
    enable: boolean;
}


Но это не работает. Подскажите, как решить этот вопрос. Спасибо!
  • Вопрос задан
  • 30 просмотров
Пригласить эксперта
Ответы на вопрос 2
mmmaaak
@mmmaaak
тебе нужен Declaration Merge, можешь загуглить, как пример:
declare module 'swiper' {
  interface AutoplayOptions {
   // тут новые свойства, которыми нужно расширить библиотечный интерфейс
  }
}
Ответ написан
vabka
@vabka
Токсичный шарпист
Однако, как я понял типы описаны не все. Конкретно я получаю такую ошибку.

Как понял?
Мне вот кажется, что ты выдумываешь какие-то несуществующие параметры, или существовавшие в старых версиях, тк ни о каком enable или enabled в документации нет ни слова:
https://swiperjs.com/swiper-api#autoplay-parameters
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы