@eugene159

Можно ли менять версию компилятора SCSS? Если да, то как это делается?

Когда-то давно я использовал Ruby для компиляции SASS в CSS. И все было хорошо. Сейчас Ruby считается устаревшим и не рекомендуется для компиляции SASS.

Я поставил Dart. Стал компилировать им. Он это делает гораздо быстрее и поддерживает новые возможности.
Но у меня стали сыпаться ошибки. Например, вот этот код выдает ошибку:
$main_color: #333333;
background:  $main_color  + 70;

Дело в том, что в новой версии SASS убрали поддержку такого сложения цветов.

Мне часто приходится работать со старыми сайтами. И менять в них код, выдающий ошибки, когда нужно дописать всего пару строк кода для добавления, скажем, новой кнопки, - это такой себе вариант.

Можно ли использовать для компиляции Dart, но так, чтобы не приходилось исправлять кучу ошибок из-за того, что SASS код писался давно? То есть можно ли как-то менять версию компилятора SASS для Dart (или других языков для компиляции)?
  • Вопрос задан
  • 24 просмотра
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы