@MikUrrey

Как уладить проблему с Сomposer 1.x.x?

При попытке обновления пакета php composer.phar -vvv update yiisoft/yii2
вываливается исключение:
[Composer\Repository\InvalidRepositoryException]                                                                                   
  No valid bower.json was found in any branch or tag of https://github.com/getsentry/raven-js-bower.git, could not load a package from it.

Можно как то \то устранить, если
а) нельзя использовать composer 2.x.x
б) крайне нежелательно сносить composer.lock
  • Вопрос задан
  • 45 просмотров
Пригласить эксперта
Ответы на вопрос 1
@MikUrrey Автор вопроса
Странно, но на следующий день все сработало без ошибок. Подозреваю, что это мог быть github'овский rate limit, но не уверен в этом полностью.
Возможно, кому-то будет полезен совет: если не нашли решения подобной проблемы, попробуйте сделать то же самое через сутки.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы