evgenijpopov
@evgenijpopov
учусь фронтэнду понемногу

Зачем нужна строчка require_once(ABSPATH. 'wp-admin/includes/upgrade.php'); при обновлении таблицы sql wordpress?

Привет
Зачем эта строчка в куске кода
----------------------------------------
function update_table() {
global $wpdb;

require_once(ABSPATH . 'wp-admin/includes/upgrade.php');

$table_name = $wpdb->get_blog_prefix() . 'test_table';
$charset_collate = "DEFAULT CHARACTER SET {$wpdb->charset} COLLATE {$wpdb->collate}";

$sql = "CREATE TABLE {$table_name} (
id bigint(20) unsigned NOT NULL auto_increment,
address varchar(255) NOT NULL default '',
alert varchar(20) NOT NULL default '',
meta longtext NOT NULL default '',
new_meta longtext NOT NULL default '',
PRIMARY KEY (id),
KEY alert (alert)
)
{$charset_collate};";

dbDelta($sql);
}

update_table();
  • Вопрос задан
  • 25 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы