Сейчас вроде наконец-то заработало, и даже DHCP на свитче начал выдавать адреса.
В итоге не ясно, интернет будет ли во всех vlan'ах, в т.ч. в транковых портах (через порт получает корректный адрес, vlan и доступ в интернет)?
Роутер, являясь шлюзом по умолчанию, просто переадресовывает, весь остальной inter-vlan routing осуществляет свитч?
Какие корректно прописать статичные маршруты на роутере, учитывая специфику интерфейса, что не все рекомендуемые маршруты возможно применить.
Нужно ли роутеру знать про существующие VLAN'ы или хотя-бы подсети? (понятно, что скорее нет, чем да, но форуме поддержки cisco у пользователя с шильдиком циско, есть
такое мнениеWith RV320 being in place for only natting you would have to make the router aware of all the subnets or vlans. First create the vlans under vlan membership. After thats done you would need to configure static routes under Setup>>advance Routing. Point all static subnets or vlans to the Gateway of the Catalyst. Lastly, not sure if you had a P2P link involving a /30. This is mainly a static set for GW of the router with subnet of 255.255.255.252. Hope this helps you.
Буду признателен за любые советы
*10.10.1.254 - роутер
10.10.1.1 - свитч
config-file-header
CiscoSG300
v1.4.1.3 / R800_NIK_1_4_194_194
CLI v1.0
set system mode router
file SSD indicator excluded
@
no cdp appliance-tlv enable
port jumbo-frame
vlan database
vlan 10,20,30,40
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
ip dhcp server
ip dhcp pool network hosts
address low 10.10.10.100 high 10.10.10.150 255.255.255.0
domain-name lab.local
default-router 10.10.10.1
time-server 91.226.136.138
dns-server 77.88.8.8
exit
ip dhcp pool network native
address low 10.10.1.100 high 10.10.1.150 255.255.255.0
domain-name lab.local
default-router 10.10.1.1
time-server 91.226.136.138
dns-server 77.88.8.8
exit
ip dhcp pool network VMkernel
address low 10.10.30.100 high 10.10.30.150 255.255.255.0
domain-name lab.local
default-router 10.10.30.1
time-server 91.226.136.138
dns-server 77.88.8.8
exit
ip dhcp pool network Vmnetwork
address low 10.10.20.100 high 10.10.20.150 255.255.255.0
default-router 10.10.20.1
time-server 91.226.136.138
dns-server 77.88.8.8
exit
bonjour interface range vlan 1
hostname CiscoSG300
line console
exec-timeout 0
exit
line ssh
exec-timeout 0
exit
username cisco password encrypted 5b58010b3ffce92d970c08997a8a65de62a4ffa0 privilege 15
ip ssh server
ip http timeout-policy 0 https-only
clock timezone " " +3
clock source sntp
sntp unicast client enable
sntp unicast client poll
sntp server ntp1.stratum1.ru poll
sntp server ntp1.stratum2.ru poll
ip name-server 77.88.8.8
!
interface vlan 1
ip address 10.10.1.1 255.255.255.0
no ip address dhcp
!
interface vlan 10
name Hosts
ip address 10.10.10.1 255.255.255.0
!
interface vlan 20
name VMnetwork
ip address 10.10.20.1 255.255.255.0
!
interface vlan 30
name VMkernel
ip address 10.10.30.1 255.255.255.0
!
interface vlan 40
name Instance
ip address 10.10.40.1 255.255.255.0
!
interface gigabitethernet1
spanning-tree portfast
switchport mode access
switchport access vlan 10
!
interface gigabitethernet2
spanning-tree portfast
switchport mode access
switchport access vlan 10
!
interface gigabitethernet3
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport mode access
switchport access vlan 10
macro description host
macro auto smartport dynamic_type unknown
!
interface gigabitethernet4
spanning-tree portfast
switchport mode access
switchport access vlan 10
!
interface gigabitethernet5
spanning-tree portfast
switchport mode access
switchport access vlan 10
!
interface gigabitethernet6
spanning-tree portfast
switchport mode access
switchport access vlan 10
!
interface gigabitethernet22
spanning-tree portfast
switchport mode access
switchport access vlan 20
!
interface gigabitethernet23
spanning-tree portfast
switchport mode access
switchport access vlan 30
!
interface gigabitethernet24
spanning-tree portfast
switchport mode access
switchport access vlan 40
!
interface gigabitethernet27
gvrp enable
spanning-tree link-type point-to-point
switchport trunk allowed vlan add 10,20,30,40
macro description switch
macro auto smartport type switch $native_vlan 1
!
interface gigabitethernet28
gvrp enable
storm-control broadcast enable
storm-control broadcast level 10
spanning-tree link-type point-to-point
switchport mode access
macro description "router "
!next command is internal.
macro auto smartport dynamic_type router
!
exit
macro auto enabled
macro auto processing type host enabled
macro auto processing type ip_phone disabled
macro auto processing type ip_phone_desktop disabled
macro auto processing type router enabled
ip default-gateway 10.10.1.254