Ответы пользователя по тегу Node.js
  • Нужно ли с EventEmitter заботиться об освобождении памяти?

    VladimirZhid
    @VladimirZhid
    Нравится делать что-то интересное и полезное.
    Может быть я не до конца компетентен в этом вопросе и сам ошибаюсь, но утечки не видно
    Утечка памяти может происходить если "долгоживущий" объект ссылается на "короткоживущий"
    когда ты пишешь:
    down.on('event', () => this.emit);

    у down в массиве events добавляется ссылка на метод emit в экземпляре класса Up, если не будет экземпляра класса Up то и не будет ссылок на него из down. Проблема может быть если экземпляр класса Up тоже подпишется на события в down
    Если что, то сорри за сумбурность.
    Если кто-то прочитает и увидит в этом ответе ошибку, призываю поправить, мне это тоже будет полезно)
    Ответ написан
  • Как завершить async waterfall?

    VladimirZhid
    @VladimirZhid
    Нравится делать что-то интересное и полезное.
    А точно ли здесь нужен waterfall? Получение кеша блокирующая операция? Если да, то можно и обернуть в обычный промис. По твоему описанию мне кажется что можно сделать и без waterfall
    waterfall как бе нужен для последовательного запуска функций с блокирующими операциями и возможностью передачи агрументов от одной к следующей...
    Ответ написан
  • Перестал запускаться node. Что делать?

    VladimirZhid
    @VladimirZhid
    Нравится делать что-то интересное и полезное.
    Что пишет если запускать не через forever?
    Ответ написан
  • Как обновить таски (package.json)?

    VladimirZhid
    @VladimirZhid
    Нравится делать что-то интересное и полезное.
    Ну насколько я понял вам надо обновить зависимости, а не таски.
    Таски это команды bash, которые вы можете сохранять в package.json и вызывать их с помошью команды npm run task_name, используются в случаях если вам не хочется часто вводить подобную : node index.js --some-param1 --some-param2 123 --log команду слишком часто, вы ее сохраняете в таске и потом запускаете с помошью команды npm run task_name

    По поводу обновления пакетов(зависимостей).
    Все зависимости у вас указаны в поле "dependencies" и "devDependencies"(модули которые используются для разработки, например сборщик webpack)

    Для каждой зависимости указана ее версия по синтаксису semver(если это так можно назвать)
    Пример:
    "dependencies": {
        "python-shell": "^0.4.0"
    }

    Такая запись версии: ^1.2.3 говорит, что версия может быть выше чем 1.2.3 но не более 2.0.0 следовательно при команде:
    npm update все зависимости обновятся, если есть более новая версия
    Более подробно немного здесь: https://www.youtube.com/watch?v=CrevZgTc7ow
    Ответ написан