gaisindanil
@gaisindanil
web developer

В чем ошибка во время компиляции?

Добрый день, при компиляции Angular проекта вылетает в чем ошибка, не могу разобраться.
Моя версия node: v12.19.0
Вот последний лог компилятора
0 info it worked if it ends with ok
1 verbose cli [
1 verbose cli   'D:\\Программы\\Node js\\node.exe',
1 verbose cli   'D:\\Программы\\Node js\\node_modules\\npm\\bin\\npm-cli.js',
1 verbose cli   'run',
1 verbose cli   'build'
1 verbose cli ]
2 info using npm@6.14.8
3 info using node@v12.19.0
4 verbose run-script [ 'prebuild', 'build', 'postbuild' ]
5 info lifecycle kokos-uwidget@0.1.0~prebuild: kokos-uwidget@0.1.0
6 info lifecycle kokos-uwidget@0.1.0~build: kokos-uwidget@0.1.0
7 verbose lifecycle kokos-uwidget@0.1.0~build: unsafe-perm in lifecycle true
8 verbose lifecycle kokos-uwidget@0.1.0~build: PATH: D:\Программы\Node js\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin;D:\OpenServer\domains\ticket.kinoteatr.loc\widget\node_modules\.bin;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Python39\Scripts\;C:\Python39\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Windows\System32\OpenSSH\;D:\Программы\Putty 0.74\;D:\Программы\Node js\;C:\ProgramData\chocolatey\bin;C:\Program Files\Java\jre1.8.0_271\bin;C:\Program Files\Git\cmd;C:\Program Files (x86)\HP\IdrsOCR_15.2.10.1114\;D:\Программы\Bitvise Shh client;D:\OpenServer\modules\php\PHP_7.3;D:\OpenServer\domains\229.loc;C:\Users\Данил\AppData\Local\Microsoft\WindowsApps;C:\Program Files\JetBrains\PhpStorm 2020.2.6\bin;;C:\Users\Данил\AppData\Roaming\Composer\vendor\bin;C:\Users\Данил\AppData\Roaming\npm;D:\Программы\PyCharm 2020.2.3\bin;;
9 verbose lifecycle kokos-uwidget@0.1.0~build: CWD: D:\OpenServer\domains\ticket.kinoteatr.loc\widget
10 silly lifecycle kokos-uwidget@0.1.0~build: Args: [
10 silly lifecycle   '/d /s /c',
10 silly lifecycle   'node node_modules/webpack/bin/webpack.js && node node_modules/gulp/bin/gulp.js'
10 silly lifecycle ]
11 silly lifecycle kokos-uwidget@0.1.0~build: Returned: code: 1  signal: null
12 info lifecycle kokos-uwidget@0.1.0~build: Failed to exec build script
13 verbose stack Error: kokos-uwidget@0.1.0 build: `node node_modules/webpack/bin/webpack.js && node node_modules/gulp/bin/gulp.js`
13 verbose stack Exit status 1
13 verbose stack     at EventEmitter.<anonymous> (D:\Программы\Node js\node_modules\npm\node_modules\npm-lifecycle\index.js:332:16)
13 verbose stack     at EventEmitter.emit (events.js:314:20)
13 verbose stack     at ChildProcess.<anonymous> (D:\Программы\Node js\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)
13 verbose stack     at ChildProcess.emit (events.js:314:20)
13 verbose stack     at maybeClose (internal/child_process.js:1021:16)
13 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:286:5)
14 verbose pkgid kokos-uwidget@0.1.0
15 verbose cwd D:\OpenServer\domains\ticket.kinoteatr.loc\widget
16 verbose Windows_NT 10.0.19041
17 verbose argv "D:\\Программы\\Node js\\node.exe" "D:\\Программы\\Node js\\node_modules\\npm\\bin\\npm-cli.js" "run" "build"
18 verbose node v12.19.0
19 verbose npm  v6.14.8
20 error code ELIFECYCLE
21 error errno 1
22 error kokos-uwidget@0.1.0 build: `node node_modules/webpack/bin/webpack.js && node node_modules/gulp/bin/gulp.js`
22 error Exit status 1
23 error Failed at the kokos-uwidget@0.1.0 build script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 1, true ]


мой package-json
{
    "name": "kokos-uwidget",
    "version": "0.1.0",
    "description": "kokos uwidget",
    "main": "",
    "dependencies": {
        "@angular/common": "2.1.1",
        "@angular/compiler": "2.1.1",
        "@angular/core": "2.1.1",
        "@angular/forms": "2.1.1",
        "@angular/http": "2.1.1",
        "@angular/platform-browser": "2.1.1",
        "@angular/platform-browser-dynamic": "2.1.1",
        "@angular/router": "3.1.1",
        "core-js": "2.4.1",
        "rxjs": "5.0.0-beta.12",
        "zone.js": "0.6.25",
        "angular2-moment": "1.0.0-beta.6",
        "angular2-text-mask": "2.1.0"
    },
    "devDependencies": {
        "babel-core": "6.17.0",
        "babel-loader": "6.2.5",
        "babel-preset-angular2": "0.0.2",
        "babel-preset-latest": "6.16.0",
        "copy-webpack-plugin": "3.0.1",
        "css-loader": "0.25.0",
        "css-to-string-loader": "0.1.2",
        "raw-loader": "0.5.1",
        "resolve-url-loader": "1.6.0",
        "extract-text-webpack-plugin": "1.0.1",
        "html-loader": "0.4.4",
        "angular2-template-loader": "0.5.0",
        "progress-bar-webpack-plugin": "1.9.0",
        "source-map-loader": "0.1.5",
        "style-loader": "0.13.1",
        "file-loader": "^0.9.0",
        "url-loader": "^0.5.7",
        "webpack": "1.13.2",
        "webpack-dev-server": "1.16.2",
        "webpack-merge": "0.14.1",
        "typings": "^1.3.2",
        "gulp": "^3.9.1",
        "gulp-uglify": "^2.0.0",
        "gulp-concat": "^2.6.0",
        "gulp-minify-css": "^1.2.4",
        "gulp-replace": "0.5.4",
        "replace-webpack-plugin": "^0.1.2"
    },
    "scripts": {
        "goinstall": "npm install && bower install --allow-root",
        "build": "node node_modules/webpack/bin/webpack.js && node node_modules/gulp/bin/gulp.js",
        "watch": "node node_modules/webpack/bin/webpack.js --watch"
    }
}
  • Вопрос задан
  • 37 просмотров
Пригласить эксперта
Ответы на вопрос 1
@kttotto
все, что .NET
Зачем Вам gulp к webpack-у? С большой долей вероятности, проблема из-за него, причина ошибки в трейсе написана, это циклическая зависимость
20 error code ELIFECYCLE
21 error errno 1
22 error kokos-uwidget@0.1.0 build: `node node_modules/webpack/bin/webpack.js && node node_modules/gulp/bin/gulp.js`
22 error Exit status 1
23 error Failed at the kokos-uwidget@0.1.0 build script.
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы