@OLZ1

Не запускается графическое окружение XFCE при прохождении авторизации пользователя: в чём может быть причина?

MX Linux 19.4 patito feo
Проблема: не запускается графическое окружение XFCE при прохождении авторизации пользователя (user, не root). При авторизации с помощью root данной проблемы нет. При этом авторизация пользователем в текстовом режиме (текстовый интерфейс Ctrl+Alt+F1) выполняется успешно, и я могу работать со своим рабочим каталогом.
До появления этой проблемы я удалил несколько файлов, обновил систему и, возможно, драйвера (точно не помню, но Synaptic, менеджер драйверов открывал точно), а также выполнил тест памяти.
Мои действия: почистил cash и восстановил в root-режиме удалённые файлы, переустановил lightdm: надеялся отделаться лёгким испугом. Но, увы! проблема не решена.
Также убедился в отсутствии у меня возможных причин появления данной проблемы:
https://mxlinux.org/wiki/system/cant-log-in/
Запуск скрипта lightdm (sudo lightdm от имени пользователя) оканчивается предупреждением:
Faled to use bus name org.freedesktop.DisplayManager, do you have appropriate permissions?

Запуск скрипта startx сопровождается то появлением фатальной ошибки сервера (no screens found(EE)), то оканчивается с «заторможенным» появлением рабочего окружения для пользователя root и окошком на рабочем столе с надписью No Removable Device.
По симптомам моя проблема схожа с этой:
https://forum.mxlinux.org/viewtopic.php?t=49960
Вдохновившись её решением, создал в директории ~/.config/autostart/ файл под названием nvidea (на основе файла kbd.desktop) с начинкой как в посте #10 вышеприведённой статьи.
Как и предчувствовалось, не помогло.
Прошу совета/помощи в решении данной проблемы. Конечно, в крайнем случае, можно переустановить систему, но это не желательно для меня, поскольку в рабочем каталоге много изменённых конфигурационных (и не только) файлов, которые я подстраивал "под себя" на протяжении нескольких месяцев.
  • Вопрос задан
  • 74 просмотра
Пригласить эксперта
Ответы на вопрос 2
CityCat4
@CityCat4
Если я чешу в затылке - не беда!
Ну, во-первых, lightdm должен стартовать от рута, службой, поэтому немудрено, что do you have appropriate permissions?

Можно попробовать удалить /etc/xorg.conf (или /etc/X11/xorg.conf) если он есть. Если нет - наоборот, запустить X -configure, чтобы создался дефолтный конфиг.

И внимательно посмотреть ошибки выше строки no screen found - это просто следствие, причина должна быть выше
Ответ написан
@voleg4u
http://www.voleg.info/
Читать логи: /var/log/Xorg.0.log , ~/.xsession-errors , ~/.xfce4-session.verbose-log
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы