Ошибка при компиляции Bootstrap

Недавно начал крутить-вертеть Bootstrap. Решил собрать сам из исходников через Grunt.
В итоге при grunt получаю такую ошибку.
Если я правильно понял, то на компиляцию это никак не влияет, но ошибка просто мозолит мне глаза, да и хотелось бы понять, что это такое, зачем и почему.
Терминал
Running "exec:npmShrinkWrap" (exec) task
>> npm
>> 
>> ERR!
>> Error: Problems were encountered
>> npm
>> ERR! Please correct and try again.
>> npm ERR!
>> missing: vow@~0.3.9, required by vow-queue@0.0.2
>> npm
>> ERR! extraneous: shrinkwrap@0.4.0 /Users/v7rulnik/bootstrap/node_modules/shrinkwrap
>> npm ERR! missing: vow@~0.3.9, required by vow-queue@0.0.2
>> npm ERR!
>> at shrinkwrap_ (/usr/local/lib/node_modules/npm/lib/shrinkwrap.js:30:15)
>> npm ERR!     at /usr/local/lib/node_modules/npm/lib/shrinkwrap.js:24:5
>> npm ERR!     at /usr/local/lib/node_modules/npm/lib/ls.js:44:30
>> npm
>> ERR!     at /usr/local/lib/node_modules/npm/node_modules/read-installed/read-installed.js:130:5
>> npm
>> ERR!     at /usr/local/lib/node_modules/npm/node_modules/read-installed/read-installed.js:258:14
>> npm ERR!
>> at cb (/usr/local/lib/node_modules/npm/node_modules/slide/lib/async-map.js:48:11)
>> npm ERR!     at /usr/local/lib/node_modules/npm/node_modules/read-installed/read-installed.js:258:14
>> npm ERR!     at cb (/usr/local/lib/node_modules/npm/node_modules/slide/lib/async-map.js:48:11)
>> npm
>> ERR!     at /usr/local/lib/node_modules/npm/node_modules/read-installed/read-installed.js:258:14
>> npm
>> ERR!     at cb (/usr/local/lib/node_modules/npm/node_modules/slide/lib/async-map.js:48:11)
>> npm
>> ERR! If you need help, you may report this entire log,
>> npm ERR! including the npm and node versions, at:
>> npm ERR!
>> <http://github.com/npm/npm/issues>
>> npm ERR!
>> System Darwin 13.2.0
>> npm
>> ERR! command "node" "/usr/local/bin/npm" "shrinkwrap" "--dev"
>> npm ERR! cwd /Users/v7rulnik/bootstrap
>> npm ERR!
>> node -v v0.10.28
>> npm ERR!
>> npm -v 1.4.9
>> npm ERR!
>> npm ERR!
>> Additional logging details can be found in:
>> npm
>> 
>> ERR!     /Users/v7rulnik/bootstrap/npm-debug.log
>> npm ERR! not ok code 0
>> Exited with code: 1.
Warning: Task "exec:npmShrinkWrap" failed. Use --force to continue.

Логи
0 info it worked if it ends with ok
1 verbose cli [ 'node', '/usr/local/bin/npm', 'shrinkwrap', '--dev' ]
2 info using npm@1.4.9
3 info using node@v0.10.28
4 error Error: Problems were encountered
4 error Please correct and try again.
4 error missing: vow@~0.3.9, required by vow-queue@0.0.2
4 error extraneous: shrinkwrap@0.4.0 /Users/v7rulnik/bootstrap/node_modules/shrinkwrap
4 error missing: vow@~0.3.9, required by vow-queue@0.0.2
4 error     at shrinkwrap_ (/usr/local/lib/node_modules/npm/lib/shrinkwrap.js:30:15)
4 error     at /usr/local/lib/node_modules/npm/lib/shrinkwrap.js:24:5
4 error     at /usr/local/lib/node_modules/npm/lib/ls.js:44:30
4 error     at /usr/local/lib/node_modules/npm/node_modules/read-installed/read-installed.js:130:5
4 error     at /usr/local/lib/node_modules/npm/node_modules/read-installed/read-installed.js:258:14
4 error     at cb (/usr/local/lib/node_modules/npm/node_modules/slide/lib/async-map.js:48:11)
4 error     at /usr/local/lib/node_modules/npm/node_modules/read-installed/read-installed.js:258:14
4 error     at cb (/usr/local/lib/node_modules/npm/node_modules/slide/lib/async-map.js:48:11)
4 error     at /usr/local/lib/node_modules/npm/node_modules/read-installed/read-installed.js:258:14
4 error     at cb (/usr/local/lib/node_modules/npm/node_modules/slide/lib/async-map.js:48:11)
5 error If you need help, you may report this *entire* log,
5 error including the npm and node versions, at:
5 error     <http://github.com/npm/npm/issues>
6 error System Darwin 13.2.0
7 error command "node" "/usr/local/bin/npm" "shrinkwrap" "--dev"
8 error cwd /Users/v7rulnik/bootstrap
9 error node -v v0.10.28
10 error npm -v 1.4.9
11 verbose exit [ 1, true ]

  • Вопрос задан
  • 2752 просмотра
Пригласить эксперта
Ответы на вопрос 1
Zoxon
@Zoxon
Веб-разработчик
Попробуйте ручками установить npm-shrinkwrap
npm i npm-shrinkwrap
Ответ написан
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы