@Winchestor
начинающий программист

Когда процесс начинает работать бот типа отключается но на сервере бот ON и в журнале не показывает ошибку, не понимаю что я пропустил там?

if c.data == 'la_liga':
        print('la liga')
        con = sql.connect('users.db')
        cur = con.cursor()
        cur.execute("SELECT lang FROM users WHERE user_id = ?", (c.from_user.id,))
        use_lang = cur.fetchone()

        driver_location = '/usr/bin/chromedriver'
        binary_location = '/usr/bin/google-chrome'
        options = webdriver.ChromeOptions()
        options.binary_location = binary_location
        options.headless = True
        options.add_argument('--ignore-certificate-errors')
        options.add_argument('--headless')
        options.add_argument('--no-sandbox')
        driver = webdriver.Chrome(executable_path=driver_location, options=options)


        driver.get(url_la)

        S = lambda X: driver.execute_script('return document.body.parentNode.scroll' + X)
        driver.set_window_size(S('Width'), S(
            'Height'))

        driver.find_element_by_class_name('XUWU3c').screenshot('espani.png')
        print('screen')
        driver.quit()


Когда доходит до этого процесса бот не реагирует на все действие.
Установил на ubuntu server chromedriver и google-chrome и в коде указал на директорию где они лежали!

603b7dec9e8b1961714391.jpeg
  • Вопрос задан
  • 48 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы
23 апр. 2021, в 07:41
1500 руб./за проект
23 апр. 2021, в 07:37
15000 руб./за проект
23 апр. 2021, в 04:31
2000 руб./за проект