@n1ksON
Интерн

Что за проблема с create-react-app?

При создании проекта с помощью create-react-app появляется "1 high severity vulnerability".
npm audit:
High            Prototype Pollution                                           

  Package         immer                                                         

  Patched in      >=8.0.1                                                       

  Dependency of   react-scripts                                                 

  Path            react-scripts > react-dev-utils > immer                       

  More info       https://npmjs.com/advisories/1603                             

found 1 high severity vulnerability in 1934 scanned packages
  1 vulnerability requires manual review. See the full report for details.

При npm audit fix:
npm WARN tsutils@3.20.0 requires a peer of typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.3.2 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\watchpack-chokidar2\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\webpack-dev-server\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

up to date in 51.076s

120 packages are looking for funding
  run `npm fund` for details

fixed 0 of 1 vulnerability in 1934 scanned packages
  1 vulnerability required manual review and could not be updated


На Reddit нашёл подобную проблему, написано, что нужно забить. Раньше подобная проблема не возникала. А я не совсем понимаю, что нужно сделать?
  • Вопрос задан
  • 77 просмотров
Пригласить эксперта
Ваш ответ на вопрос

Войдите, чтобы написать ответ

Войти через центр авторизации
Похожие вопросы